Amazon Linux AMI update for kernel



Published: 2021-07-22
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2021-33909
CWE ID CWE-190
Exploitation vector Local
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
Amazon Linux AMI
Operating systems & Components / Operating system

Vendor Amazon Web Services

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Integer overflow

Risk: Medium

CVSSv3.1: 7.9 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:P/RL:O/RC:C] [PCI]

CVE-ID: CVE-2021-33909

CWE-ID: CWE-190 - Integer Overflow or Wraparound

Exploit availability: Yes

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to integer overflow during size_t-to-int conversion when creating, mounting, and deleting a deep directory structure whose total path length exceeds 1GB. An unprivileged local user can write up to 10-byte string to an offset of exactly -2GB-10B below the beginning of a vmalloc()ated kernel buffer.

Successful exploitation of vulnerability may allow an attacker to exploit the our-of-bounds write vulnerability to execute arbitrary code with root privileges.

Mitigation

Update the affected packages:

i686:
    kernel-debuginfo-4.14.238-125.422.amzn1.i686
    kernel-4.14.238-125.422.amzn1.i686
    kernel-tools-4.14.238-125.422.amzn1.i686
    kernel-tools-debuginfo-4.14.238-125.422.amzn1.i686
    kernel-devel-4.14.238-125.422.amzn1.i686
    kernel-headers-4.14.238-125.422.amzn1.i686
    perf-4.14.238-125.422.amzn1.i686
    kernel-debuginfo-common-i686-4.14.238-125.422.amzn1.i686
    kernel-tools-devel-4.14.238-125.422.amzn1.i686
    perf-debuginfo-4.14.238-125.422.amzn1.i686

src:
    kernel-4.14.238-125.422.amzn1.src

x86_64:
    kernel-devel-4.14.238-125.422.amzn1.x86_64
    kernel-headers-4.14.238-125.422.amzn1.x86_64
    kernel-debuginfo-common-x86_64-4.14.238-125.422.amzn1.x86_64
    kernel-4.14.238-125.422.amzn1.x86_64
    perf-4.14.238-125.422.amzn1.x86_64
    kernel-tools-4.14.238-125.422.amzn1.x86_64
    kernel-tools-debuginfo-4.14.238-125.422.amzn1.x86_64
    perf-debuginfo-4.14.238-125.422.amzn1.x86_64
    kernel-tools-devel-4.14.238-125.422.amzn1.x86_64
    kernel-debuginfo-4.14.238-125.422.amzn1.x86_64

Vulnerable software versions

Amazon Linux AMI: 2017.03

CPE External links

https://alas.aws.amazon.com/ALAS-2021-1524.html

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



###SIDEBAR###