Amazon Linux AMI update for containerd



Published: 2021-07-22
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2021-32760
CWE ID CWE-264
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Amazon Linux AMI
Operating systems & Components / Operating system

Vendor Amazon Web Services

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Permissions, Privileges, and Access Controls

Risk: Medium

CVSSv3.1: 6.4 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2021-32760

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to archive package allows chmod of file outside of unpack target directory. A remote attacker can deny access to the expected owner of the file, widen access to others, or set extended bits like setuid, setgid, and sticky.

Mitigation

Update the affected packages:

src:
    containerd-1.4.6-2.7.amzn1.src

x86_64:
    containerd-stress-1.4.6-2.7.amzn1.x86_64
    containerd-debuginfo-1.4.6-2.7.amzn1.x86_64
    containerd-1.4.6-2.7.amzn1.x86_64

Vulnerable software versions

Amazon Linux AMI: 2017.03

CPE External links

https://alas.aws.amazon.com/ALAS-2021-1523.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###