Remote code execution in Apple macOS



Published: 2021-07-22
Risk High
Patch available NO
Number of vulnerabilities 1
CVE-ID CVE-2021-30662
CWE-ID CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
macOS
Operating systems & Components / Operating system

Vendor Apple Inc.

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Out-of-bounds write

EUVDB-ID: #VU55255

Risk: High

CVSSv3.1:

CVE-ID: CVE-2021-30662

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error within the ImageIO framework. A remote attacker can create a specially crafted TIFF file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

macOS: 11.0 20A2411 - 11.5 20G71, 10.15 19A583 - 10.15.7 19H1323, 10.14 18A391 - 10.14.6 18G9323


CPE2.3 External links

http://www.zerodayinitiative.com/advisories/ZDI-21-891/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###