Remote code execution in FreeBSD ggatec



Published: 2021-08-25
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-29630
CWE-ID CWE-119
Exploitation vector Local network
Public exploit N/A
Vulnerable software
Subscribe
FreeBSD
Operating systems & Components / Operating system

Vendor FreeBSD Foundation

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Buffer overflow

EUVDB-ID: #VU56092

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-29630

CWE-ID: CWE-119 - Memory corruption

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in ggatec(8) daemon. A remote attacker on the local network can pass specially crafted content to the affected daemon, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

FreeBSD: 11.0 - 13.0


CPE2.3 External links

http://www.freebsd.org/security/advisories/FreeBSD-SA-21:14.ggatec.asc

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###