Remote code execution in Telnet component in Palo Alto PAN-OS



Published: 2021-09-08
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2020-10188
CWE-ID CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Palo Alto PAN-OS
Operating systems & Components / Operating system

Vendor Palo Alto Networks, Inc.

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Buffer overflow

EUVDB-ID: #VU26625

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-10188

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary involving the netclear and nextitem functions within the utility.c in telnetd daemon from netkit telnet. A remote attacker can end specially crafted data to the telnetd daemon, trigger a boundary error and execute arbitrary code on the target system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Palo Alto PAN-OS: 10.0.0 - 10.0.5, 8.1 - 8.1.19, 9.0 - 9.0.13, 9.1 - 9.1.8


CPE2.3 External links

http://security.paloaltonetworks.com/CVE-2020-10188

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###