Path traversal in Loki



Published: 2021-09-14 | Updated: 2022-06-16
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-36156
CWE-ID CWE-22
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Loki
Web applications / Other software

Vendor Grafana Labs

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Path traversal

EUVDB-ID: #VU64412

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-36156

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to input validation error when header value X-Scope-OrgID is used to construct file paths for rules files. A remote attacker can send a specially crafted HTTP request and read arbitrary files on the system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Loki: 0.1.0 - 2.2.0


CPE2.3 External links

http://github.com/grafana/loki/pull/4020#issue-694377133
http://github.com/grafana/loki/releases/tag/v2.3.0

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###