GitKraken update for keypair



Published: 2021-10-13
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-41117
CWE-ID CWE-330
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
GitKraken
Universal components / Libraries / Software for developers

Vendor GitKraken

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Use of insufficiently random values

EUVDB-ID: #VU57321

Risk: High

CVSSv3.1: 8.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-41117

CWE-ID: CWE-330 - Use of Insufficiently Random Values

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the affected system.

The vulnerability exists due to an error in the pseudo-random number generator used by keypair to generate RSA keys for SSH connections. A remote attacker can generate duplicate SSH keys and gain unauthorized access to the affected systems.

Mitigation

Install update from vendor's website.

Note, just installing an update is not enough to fix the problem. You need to replace all previously generated SSH keys.

Vulnerable software versions

GitKraken: 7.6.0, 7.6.1, 7.7.0, 7.7.1, 7.7.2, 8.0.0

CPE2.3 External links

http://www.gitkraken.com/blog/weak-ssh-key-fix

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###