Denial of service in Juniper Networks Junos OS on EX4300 Series, EX3400 Series, EX4300-MP Series and EX2300 Series



Published: 2021-10-14
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-31365
CWE-ID CWE-400
Exploitation vector Local network
Public exploit N/A
Vulnerable software
Subscribe
Juniper Junos OS
Operating systems & Components / Operating system

EX4300
Hardware solutions / Routers & switches, VoIP, GSM, etc

EX3400
Hardware solutions / Routers & switches, VoIP, GSM, etc

EX4300-MP
Hardware solutions / Routers & switches, VoIP, GSM, etc

EX2300
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor Juniper Networks, Inc.

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Resource exhaustion

EUVDB-ID: #VU57355

Risk: Low

CVSSv3.1: 5.7 [CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-31365

CWE-ID: CWE-400 - Uncontrolled Resource Consumption ('Resource Exhaustion')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly control consumption of internal resources in an Aggregated Ethernet (AE) interface. A remote attacker on the local network can trigger resource exhaustion and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Juniper Junos OS: 15.1R, 15.1R1, 15.1R2, 15.1R3, 15.1R4, 15.1R4-S1, 15.1R4-S2, 15.1R4-S3, 15.1R4-S4, 15.1R4-S5, 15.1R4-S6, 15.1R4-S7, 15.1R4-S8, 15.1R4-S9, 15.1R5, 15.1R5-S4, 15.1R5-S5, 15.1R5-S7, 15.1R5-S51, 15.1R5-S52, 15.1R5-S53, 15.1R5-S54, 15.1R5-S55, 15.1R5-S56, 15.1R5-S57, 15.1R6, 15.1R6-S1, 15.1R6-S2, 15.1R6-S3, 15.1R6-S4, 15.1R6-S5, 15.1R6-S6, 15.1R7, 15.1R7-S2, 15.1R7-S3, 15.1R7-S4, 15.1R7-S5, 15.1R7-S6, 16.1R, 16.1R1, 16.1R2, 16.1R3, 16.1R3-S1, 16.1R3-S2, 16.1R3-S3, 16.1R3-S4, 16.1R3-S5, 16.1R3-S6, 16.1R3-S7, 16.1R3-S8, 16.1R3-S10, 16.1R3-S11, 16.1R4, 16.1R4-S3, 16.1R4-S6, 16.1R4-S8, 16.1R4-S9, 16.1R4-S12, 16.1R4-S13, 16.1R5, 16.1R5-S3, 16.1R5-S4, 16.1R6, 16.1R6-S2, 16.1R6-S3, 16.1R6-S4, 16.1R6-S6, 16.1R7, 16.1R7-S1, 16.1R7-S2, 16.1R7-S3, 16.1R7-S4, 16.1R7-S5, 16.1R7-S6, 16.1R7-S7, 17.1R1, 17.1R1-S1, 17.1R1-S2, 17.1R1-S3, 17.1R1-S4, 17.1R1-S5, 17.1R1-S6, 17.1R1-S7, 17.1R2, 17.1R2-S1, 17.1R2-S2, 17.1R2-S3, 17.1R2-S4, 17.1R2-S5, 17.1R2-S6, 17.1R2-S7, 17.1R2-S8, 17.1R2-S9, 17.1R2-S10, 17.1R2-S11, 17.2R1, 17.2R1-S1, 17.2R1-S2, 17.2R1-S3, 17.2R1-S4, 17.2R1-S5, 17.2R1-S6, 17.2R1-S7, 17.2R1-S8, 17.2R1-S9, 17.2R2, 17.2R2-S1, 17.2R2-S2, 17.2R2-S3, 17.2R2-S4, 17.2R2-S6, 17.2R2-S7, 17.2R2-S8, 17.2R3, 17.2R3-S1, 17.2R3-S2, 17.2R3-S3, 17.3R1, 17.3R1-S1, 17.3R1-S2, 17.3R1-S3, 17.3R1-S4, 17.3R2, 17.3R2-S2, 17.3R2-S4, 17.3R2-S5, 17.3R3, 17.3R3-S1, 17.3R3-S2, 17.3R3-S3, 17.3R3-S4, 17.3R3-S5, 17.3R3-S6, 17.3R3-S7, 17.4R1, 17.4R1-S1, 17.4R1-S2, 17.4R1-S3, 17.4R1-S4, 17.4R1-S5, 17.4R1-S6, 17.4R1-S7, 17.4R1-S8, 17.4R2, 17.4R2-S1, 17.4R2-S2, 17.4R2-S3, 17.4R2-S4, 17.4R2-S5, 17.4R2-S6, 17.4R2-S7, 17.4R2-S8, 17.4R2-S9, 17.4R3, 17.4R3-S1, 18.1R1, 18.1R2, 18.1R2-S2, 18.1R2-S3, 18.1R2-S4, 18.1R3, 18.1R3-S1, 18.1R3-S2, 18.1R3-S3, 18.1R3-S4, 18.1R3-S5, 18.1R3-S6, 18.1R3-S7, 18.1R3-S8, 18.1R3-S9, 18.1R3-S11, 18.1R4, 18.2R1, 18.2R1-S3, 18.2R1-S4, 18.2R1-S5, 18.2R2, 18.2R2-S1, 18.2R2-S2, 18.2R2-S3, 18.2R2-S4, 18.2R2-S5, 18.2R2-S6, 18.2R3, 18.2R3-S1, 18.2R3-S2, 18.2R3-S3, 18.2R3-S4, 18.2R3-S5, 18.2R3-S6, 18.3R1, 18.3R1-S1, 18.3R1-S2, 18.3R1-S3, 18.3R1-S4, 18.3R1-S5, 18.3R1-S6, 18.3R1-S7, 18.3R2, 18.3R2-S1, 18.3R2-S2, 18.3R2-S3, 18.3R3, 18.3R3-S1, 18.3R3-S3, 18.4R1, 18.4R1-S1, 18.4R1-S2, 18.4R1-S3, 18.4R1-S4, 18.4R1-S5, 18.4R1-S6, 18.4R1-S8, 18.4R2, 18.4R2-S1, 18.4R2-S2, 18.4R2-S3, 18.4R2-S5, 18.4R2-S6, 18.4R2-S7, 18.4R2-S8, 18.4R3, 18.4R3-S2, 18.4R3-S3, 18.4R3-S4, 18.4R3-S5, 18.4R3-S6, 18.4R3-S8, 19.1R, 19.1R1, 19.1R1-S1, 19.1R1-S2, 19.1R1-S3, 19.1R1-S4, 19.1R1-S6, 19.1R2, 19.1R2-S2, 19.1R3-S1, 19.1R3-S2, 19.1R3-S3, 19.1R3-S5, 19.2R1, 19.2R1-S1, 19.2R1-S2, 19.2R1-S3, 19.2R1-S4, 19.2R2-S1, 19.2R3, 19.2R3-S2, 19.3R1, 19.3R1-S1, 19.3R2, 19.3R2-S1, 19.3R2-S3, 19.3R2-S4, 19.3R2-S5, 19.3R2-S6, 19.3R3-S2, 19.4R1, 19.4R1-S1, 19.4R1-S3, 19.4R1-S4, 19.4R2, 19.4R2-S1, 19.4R2-S2, 19.4R2-S3, 19.4R2-S4, 19.4R2-S5, 19.4R3, 19.4R3-S2, 19.4R3-S3, 19.4R3-S4, 20.1R1, 20.1R1-S1, 20.1R1-S2, 20.1R1-S3, 20.1R1-S4, 20.1R2, 20.1R2-S1, 20.2R1, 20.2R1-S1, 20.2R1-S2, 20.2R1-S3, 20.2R2, 20.2R2-S1, 20.2R2-S2, 20.2R2-S3, 20.2R3-S1, 20.3R1, 20.3R1-S1, 20.3R1-S2, 20.3R2-S1, 20.3R3, 20.4R1, 20.4R1-S1, 20.4R2, 21.1R1, 21.1R1-S1

EX4300: All versions

EX3400: All versions

EX4300-MP: All versions

EX2300: All versions

CPE2.3 External links

http://kb.juniper.net/InfoCenter/index?page=content&id=JSA11227&cat=SIRT_1&actp=LIST

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the local network (LAN).

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###