Denial of service in Juniper Networks Junos OS on MX Series



Published: 2021-10-14
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-31351
CWE-ID CWE-754
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Juniper Junos OS
Operating systems & Components / Operating system

MX Series
Hardware solutions / Firmware

Vendor Juniper Networks, Inc.

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Improper Check for Unusual or Exceptional Conditions

EUVDB-ID: #VU57357

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-31351

CWE-ID: CWE-754 - Improper Check for Unusual or Exceptional Conditions

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper check for unusual or exceptional conditions in packet processing on the MS-MPC/MS-MIC. A remote attacker can pass specially crafted input to the application and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Juniper Junos OS: 17.3R3-S11, 17.4R2-S13, 17.4R3, 17.4R3-S1, 17.4R3-S2, 17.4R3-S3, 17.4R3-S4, 18.1R3-S12, 18.2R2-S8, 18.2R3-S7, 18.2R3-S8, 18.3R3-S4, 18.4R3-S7, 19.1R3-S4, 19.1R3-S5, 19.2R1-S6, 19.3R3-S2, 19.4R2-S4, 19.4R2-S5, 19.4R3-S2, 20.1R2-S1, 20.2R2-S2, 20.2R3, 20.2R3-S3, 20.3R2, 20.3R2-S1, 20.4R1, 20.4R1-S1, 20.4R2, 21.1R1

MX Series: All versions

CPE2.3 External links

http://kb.juniper.net/InfoCenter/index?page=content&id=JSA11216&cat=SIRT_1&actp=LIST

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###