Remote code execution in EntroLink PPX-AnyLink devices



Published: 2021-10-26
Risk Critical
Patch available NO
Number of vulnerabilities 1
CVE-ID N/A
CWE-ID CWE-94
Exploitation vector Network
Public exploit This vulnerability is being exploited in the wild.
Vulnerable software
Subscribe
PPX-AnyLink 8000
Hardware solutions / Routers & switches, VoIP, GSM, etc

PPX-AnyLink 6904
Hardware solutions / Routers & switches, VoIP, GSM, etc

PPX-AnyLink 6900
Hardware solutions / Routers & switches, VoIP, GSM, etc

PPX-AnyLink 6900F
Hardware solutions / Routers & switches, VoIP, GSM, etc

PPX-AnyLink 6006
Hardware solutions / Routers & switches, VoIP, GSM, etc

PPX-AnyLink 6004
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor EntroLink

Security Bulletin

This security bulletin contains one critical risk vulnerability.

1) Code Injection

EUVDB-ID: #VU57645

Risk: Critical

CVSSv3.1: 9.1 [CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H/E:H/RL:U/RC:C]

CVE-ID: N/A

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: No

Description

The vulnerability allows a remote user to execute arbitrary code on the target system.

The vulnerability exists due to improper input validation. A remote administrator can execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Note, the vulnerability is being actively exploited in the wild.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

PPX-AnyLink 8000: All versions

PPX-AnyLink 6904: All versions

PPX-AnyLink 6900: All versions

PPX-AnyLink 6900F: All versions

PPX-AnyLink 6006: All versions

PPX-AnyLink 6004: All versions

CPE2.3 External links

http://therecord.media/ransomware-gangs-are-abusing-a-zero-day-in-entrolink-vpn-appliances/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected device in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

Yes. This vulnerability is being exploited in the wild.



###SIDEBAR###