Privilege escalation in Google Android



Published: 2021-11-03
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-1048
CWE-ID CWE-416
Exploitation vector Local
Public exploit This vulnerability is being exploited in the wild.
Vulnerable software
Subscribe
Google Android
Operating systems & Components / Operating system

Vendor Google

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Use-after-free

EUVDB-ID: #VU57890

Risk: High

CVSSv3.1: 8.4 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H/RL:O/RC:C]

CVE-ID: CVE-2021-1048

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a malicious application to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the Android kernel component within the epoll_loop_check_proc() function. A malicious application can trigger a use-after-free error and execute arbitrary code with kernel privileges.

Note, the vulnerability is being actively exploited in the wild.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Google Android: 9 2021-09-01 - 9.0 2021-06-05, 10 - 10 2021-11-05, 11 - 11 2021-11-05, 12 - 12 2021-11-05


CPE2.3 External links

http://source.android.com/security/bulletin/2021-11-01
http://android.googlesource.com/kernel/common/+/77f4689de17c0887775bb77896f4cc11a39bf848

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

Yes. This vulnerability is being exploited in the wild.



###SIDEBAR###