Remote code execution in PAN-OS GlobalProtect Portal and Gateway interfaces



Published: 2021-11-11 | Updated: 2021-11-11
Risk Critical
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-3064
CWE-ID CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Palo Alto PAN-OS
Operating systems & Components / Operating system

Vendor Palo Alto Networks, Inc.

Security Bulletin

This security bulletin contains one critical risk vulnerability.

1) Memory corruption

EUVDB-ID: #VU58105

Risk: Critical

CVSSv3.1:

CVE-ID: CVE-2021-3064

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in the PAN-OS firewall configurations with a GlobalProtect portal or gateway enabled. A remote non-authenticated attacker can send a specially crafted request to the system, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Palo Alto PAN-OS: 8.1 - 8.1.16


CPE2.3 External links

http://security.paloaltonetworks.com/CVE-2021-3064
http://www.randori.com/blog/cve-2021-3064/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###