Improper Authentication in Nomad



Published: 2021-11-23
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-43415
CWE-ID CWE-287
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Nomad
Server applications / Virtualization software

Vendor HashiCorp

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Improper Authentication

EUVDB-ID: #VU58328

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-43415

CWE-ID: CWE-287 - Improper Authentication

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass authentication process.

The vulnerability exists due to an error in when processing authentication requests in QEMU task driver. A remote authenticated attacker can bypass the configured allowed paths for images.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Nomad: 1.2.0, 1.0.0 - 1.0.13, 1.1.0 - 1.1.7


CPE2.3 External links

http://github.com/hashicorp/nomad/releases/tag/v1.2.1
http://github.com/hashicorp/nomad/issues/11542

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###