Path traversal in Grafana



Published: 2021-12-10 | Updated: 2022-06-16
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-43815
CWE-ID CWE-22
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Grafana
Web applications / Other software

Vendor Grafana Labs

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Path traversal

EUVDB-ID: #VU64404

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-43815

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote user to perform directory traversal attacks.

The vulnerability exists due to input validation error when processing .csv files. A remote user can send a specially crafted HTTP request and read arbitrary files on the system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Grafana: 8.3.0 - 8.3.1, 8.2.0 - 8.2.7, 8.1.0 - 8.1.8, 8.0.0 - 8.0.7, 7.5.0 - 7.5.11, 7.4.0 - 7.4.5, 7.3.0 - 7.3.10, 7.2.0 - 7.2.3, 7.1.0 - 7.1.5, 7.0.0 - 7.0.6, 6.7.0 - 6.7.6, 6.6.0 - 6.6.2, 6.5 - 6.5.3, 6.4.0 - 6.4.5, 6.3.0 - 6.3.7, 6.2.0 - 6.2.5, 6.1.0 - 6.1.6, 6.0.0 - 6.0.2, 5.4.0 - 5.4.5, 5.3.0 - 5.3.4, 5.2.0 - 5.2.5, 5.1.0 - 5.1.5, 5.0.0 - 5.0.4, 4.6.0 - 4.6.5, 4.5.0 - 4.5.2, 4.4.0 - 4.4.3, 4.3.0 - 4.3.2, 4.2.0 - 4.2.0 -, 4.1.0 - 4.1.2, 4.0.0 - 4.0.2, 3.1.0 - 3.1.1, 3.0 - - 3.0.4, 2.6.0 - 2.6.0 -, 2.5.0, 2.1.0 - 2.1.3, 2.0.0 - 2.0.2, 1.9.0 - 1.9.1, 1.8.0 - 1.8.1, 1.7.0 - 1.7.0 rc1, 1.6.0 - 1.6.1, 1.5.0 - 1.5.4, 1.4.0, 1.3.0, 1.2.0, 1.1.0, 1.0 - 1.0.4


CPE2.3 External links

http://github.com/grafana/grafana/security/advisories/GHSA-7533-c8qv-jm9m
http://github.com/grafana/grafana/commit/fd48aee61e4328aae8d5303a9efd045fa0ca308d
http://grafana.com/blog/2021/12/10/grafana-8.3.2-and-7.5.12-released-with-moderate-severity-security-fix/
http://github.com/grafana/grafana/commit/d6ec6f8ad28f0212e584406730f939105ff6c6d3
http://bugzilla.redhat.com/show_bug.cgi?id=2032574

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###