Debian update for apache-log4j2



Published: 2021-12-12 | Updated: 2022-11-13
Risk Critical
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2021-44228
CVE-2020-9488
CWE-ID CWE-94
CWE-295
Exploitation vector Network
Public exploit Vulnerability #1 is being exploited in the wild.
Vulnerable software
Subscribe
apache-log4j2 (Debian package)
Operating systems & Components / Operating system package or component

Vendor Debian

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Code Injection

EUVDB-ID: #VU58816

Risk: Critical

CVSSv3.1:

CVE-ID: CVE-2021-44228

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: Yes

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to improper input validation when processing LDAP requests. A remote attacker can send a specially crafted request to the application and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Note, we are aware of attackers exploiting the vulnerability in the wild.

Mitigation

Update apache-log4j2 package to one of the following versions: 2.15.0-1~deb10u1, 2.15.0-1~deb11u1.

Vulnerable software versions

apache-log4j2 (Debian package): 2.0~beta9 - 2.15.0-1~deb11u1


CPE2.3 External links

http://www.debian.org/security/2021/dsa-5020
http://www.debian.org/security/2021/dsa-5022

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Improper Certificate Validation

EUVDB-ID: #VU27487

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2020-9488

CWE-ID: CWE-295 - Improper Certificate Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform man-in-the-middle attack.

The vulnerability exists due to the Apache Log4j SMTP appender does not validate SSL certificates. A remote attacker can perform a MitM attack, intercept and decrypt network traffic.

Mitigation

Update apache-log4j2 package to one of the following versions: 2.15.0-1~deb10u1, 2.15.0-1~deb11u1.

Vulnerable software versions

apache-log4j2 (Debian package): 2.0~beta9 - 2.11.2-1


CPE2.3 External links

http://www.debian.org/security/2021/dsa-5020

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###