Denial of service in HashiCorp Vault



Published: 2021-12-17 | Updated: 2022-08-04
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-45042
CWE-ID CWE-264
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Vault Enterprise
Web applications / Modules and components for CMS

Vault
Web applications / Modules and components for CMS

Vendor HashiCorp

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Permissions, Privileges, and Access Controls

EUVDB-ID: #VU66116

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-45042

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly impose security restrictions in clusters using the Integrated Storage backend. A remote user with write permissions to a kv secrets engine can cause a panic and denial of service of the storage backend.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Vault Enterprise: 1.9.0, 1.8.0 - 1.8.5, 1.7.0 - 1.7.6, 1.6.0 - 1.6.7, 1.5.0 - 1.5.9, 1.4.0 - 1.4.7

Vault: 1.9.0, 1.8.0 - 1.8.5, 1.7.0 - 1.7.6, 1.6.0 - 1.6.7, 1.5.0 - 1.5.9, 1.4.0 - 1.4.7


CPE2.3 External links

http://discuss.hashicorp.com/t/hcsec2-21-33-vault-s-kv-secrets-engine-with-integrated-storage-exposed-to-authenticated-denial-of-service/33157
http://www.hashicorp.com/blog/category/vault

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###