Ubuntu update for firefox



Published: 2021-12-20
Risk High
Patch available YES
Number of vulnerabilities 10
CVE-ID CVE-2021-43536
CVE-2021-43537
CVE-2021-43538
CVE-2021-43539
CVE-2021-43540
CVE-2021-43541
CVE-2021-43542
CVE-2021-43543
CVE-2021-43545
CVE-2021-43546
CWE-ID CWE-200
CWE-704
CWE-451
CWE-416
CWE-264
CWE-20
CWE-254
CWE-835
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Ubuntu
Operating systems & Components / Operating system

firefox (Ubuntu package)
Operating systems & Components / Operating system package or component

Vendor Canonical Ltd.

Security Bulletin

This security bulletin contains information about 10 vulnerabilities.

1) Information disclosure

EUVDB-ID: #VU58585

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-43536

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to URL leakage when executing asynchronous functions. A remote attacker can trick the victim to open a specially crafted web page and reveal the URL of the page that is being visited afterwards.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Type conversion

EUVDB-ID: #VU58586

Risk: High

CVSSv3.1:

CVE-ID: CVE-2021-43537

CWE-ID: CWE-704 - Incorrect Type Conversion or Cast (Type Conversion)

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the affected system.

The vulnerability exists due to a type conversion error when processing sizes from 64bit to 32bit integers when using structured clone. A remote attacker can trick the victim to visit a specially crafted web page, trigger a heap-based buffer overflow and execute arbitrary code on the system.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Spoofing attack

EUVDB-ID: #VU58607

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-43538

CWE-ID: CWE-451 - User Interface (UI) Misrepresentation of Critical Information (Clickjacking, spoofing)

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform spoofing attack.

The vulnerability exists due to a race in notification code. A remote attacker can hide the notification for pages that had received full screen and pointer lock access. Successful exploitation of the vulnerability may allow an attacker to perform spoofing attack.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Use-after-free

EUVDB-ID: #VU58608

Risk: High

CVSSv3.1:

CVE-ID: CVE-2021-43539

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error in GC rooting when calling wasm instance methods. A remote attacker can trick the victim to open a specially crafted web page, trigger a use-after-free error and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Permissions, Privileges, and Access Controls

EUVDB-ID: #VU58610

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-43540

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to an error with WebExtensions that causes a WebExtension with the correct permissions to create and install ServiceWorkers for third-party websites that cannot be uninstalled with the extension.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Input validation error

EUVDB-ID: #VU58611

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-43541

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to insufficient validation of user-supplied input when handling spaces in URLS with external protocol handlers. A remote attacker can trick the victim to click on a specially crafted link and pass unescaped input to a third-party application via URI handler.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Information disclosure

EUVDB-ID: #VU58612

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-43542

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to the way Firefox handles XMLHttpRequest requests. A remote attacker can initiate a XMLHttpRequest and identify installed applications by probing error messages for loading external protocols.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Security features bypass

EUVDB-ID: #VU58613

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-43543

CWE-ID: CWE-254 - Security Features

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to an error when handling CSP policies. Documents loaded with the CSP sandbox directive can escape the sandbox's script restriction by embedding additional content.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

9) Infinite loop

EUVDB-ID: #VU58615

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-43545

CWE-ID: CWE-835 - Loop with Unreachable Exit Condition ('Infinite Loop')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to infinite loop when using Location API. A remote attacker can consume all available system resources and cause denial of service conditions.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

10) Spoofing attack

EUVDB-ID: #VU58616

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-43546

CWE-ID: CWE-451 - User Interface (UI) Misrepresentation of Critical Information (Clickjacking, spoofing)

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform spoofing attack.

The vulnerability exists due to incorrect processing of user-supplied data, when native cursor is zoomed. A remote attacker can perform cursor spoofing attack.

Mitigation

Update the affected package firefox to the latest version.

Vulnerable software versions

Ubuntu: 21.10, 21.04, 20.04, 18.04

firefox (Ubuntu package): before 95.0.1+build2-0ubuntu0.20.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5186-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###