Privilege escalation in Siemens SICAM PQ Analyzer



Published: 2022-01-11
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-45460
CWE-ID CWE-428
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
SICAM PQ Analyzer
Hardware solutions / Security hardware applicances

Vendor Siemens

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Unquoted Search Path or Element

EUVDB-ID: #VU59365

Risk: Low

CVSSv3.1: 5.8 [CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-45460

CWE-ID: CWE-428 - Unquoted Search Path or Element

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exits due to unquoted search path when loading files. A local user with ability to write files into the C:\ root folder can place a malicious binary, such as "C:\Program.exe", "C:\Program.com", or "C:\Program.msi" and execute arbitrary code on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

SICAM PQ Analyzer: 3.0 - 3.17


CPE2.3 External links

http://cert-portal.siemens.com/productcert/txt/ssa-173318.txt

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###