Incorrect Comparison in BIG-IP virtual server with FastL4 profile



Published: 2022-01-20
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-23027
CWE-ID CWE-697
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
BIG-IP
Hardware solutions / Firmware

Vendor F5 Networks, Inc.

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Incorrect Comparison

EUVDB-ID: #VU59885

Risk: Medium

CVSSv3.1: 4.6 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-23027

CWE-ID: CWE-697 - Incorrect Comparison

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to incorrect comparison when a FastL4 profile and an HTTP, FIX, and/or hash persistence profile are configured on the same virtual server. A remote attacker can perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

BIG-IP: 11.6.5.2 - 15.1.3


CPE2.3 External links

http://support.f5.com/csp/article/K30573026

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###