Remote code execution in libexpat



Published: 2022-01-25 | Updated: 2022-09-21
Risk High
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2022-23852
CVE-2022-23990
CWE-ID CWE-190
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
expat
Universal components / Libraries / Libraries used by multiple products

Vendor libexpat.org

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

Updated: 28.01.2022

Added vulnerability #2.

1) Integer overflow

EUVDB-ID: #VU59966

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-23852

CWE-ID: CWE-190 - Integer Overflow or Wraparound

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to integer overflow in XML_GetBuffer, for configurations with a nonzero XML_CONTEXT_BYTES. A remote attacker can pass specially crafted data to the application, trigger integer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

expat: 2.0.0 - 2.4.3


CPE2.3 External links

http://github.com/libexpat/libexpat/pull/550

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Integer overflow

EUVDB-ID: #VU60114

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-23990

CWE-ID: CWE-190 - Integer Overflow or Wraparound

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to integer overflow in the doProlog() function. A remote attacker can pass specially crafted data to the application, trigger integer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

expat: 2.0.0 - 2.4.3


CPE2.3 External links

http://github.com/libexpat/libexpat/pull/551

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###