Improper input validation in Oracle Retail Xstore Point of Service



Published: 2022-02-01
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-2351
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Oracle Retail Xstore Point of Service
Other software / Other software solutions

Vendor Oracle

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Improper input validation

EUVDB-ID: #VU55044

Risk: High

CVSSv3.1:

CVE-ID: CVE-2021-2351

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

The vulnerability exists due to improper input validation within the Advanced Networking Option in Oracle Database Server. A remote non-authenticated attacker can exploit this vulnerability to execute arbitrary code.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Retail Xstore Point of Service: 17.0.4 - 20.0.1


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujan2022.html?3296

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###