Multiple vulnerabilities in Siemens Mendix Forgot Password Appstore module



Published: 2022-03-10
Risk High
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2022-26314
CVE-2022-26313
CWE-ID CWE-307
CWE-284
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Mendix Forgot Password Appstore module
Other software / Other software solutions

Mendix Forgot Password Appstore module (Mendix 7 compatible)
Other software / Other software solutions

Vendor Siemens

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Improper Restriction of Excessive Authentication Attempts

EUVDB-ID: #VU61234

Risk: Medium

CVSSv3.1: 6.4 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-26314

CWE-ID: CWE-307 - Improper Restriction of Excessive Authentication Attempts

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to initial passwords are generated in an insecure manner. A remote attacker can perform a brute-force attack and gain valid credentials.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Mendix Forgot Password Appstore module: 3.3.0

Mendix Forgot Password Appstore module (Mendix 7 compatible): before 3.2.2


CPE2.3 External links

http://cert-portal.siemens.com/productcert/pdf/ssa-134279.pdf

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Improper access control

EUVDB-ID: #VU61235

Risk: High

CVSSv3.1: 7.9 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-26313

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.

The vulnerability exists due to improper access restrictions. A remote attacker can use the sign up flow to hijack arbitrary user accounts.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Mendix Forgot Password Appstore module: 3.3.0


CPE2.3 External links

http://cert-portal.siemens.com/productcert/pdf/ssa-134279.pdf

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###