Buffer overflow in Middleware Common Libraries and Tools



Published: 2022-04-22
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-30129
CWE-ID CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Middleware Common Libraries and Tools
Server applications / Other server solutions

Vendor Oracle

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Buffer overflow

EUVDB-ID: #VU56931

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-30129

CWE-ID: CWE-119 - Memory corruption

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error in the sshd-core of Apache Mina SSHD. A remote attacker can send specially crafted requests to the server, trigger buffer overflow and perform a denial of service (DoS) attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Middleware Common Libraries and Tools: 12.2.1.3.0 - 14.1.1.0.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpuapr2022.html?952644

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###