Improper initialization in PostgreSQL JDBC driver



Published: 2022-05-02
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-21724
CWE-ID CWE-665
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Postgresql JDBC Driver
Universal components / Libraries / Libraries used by multiple products

Vendor PostgreSQL Global Development Group

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Improper initialization

EUVDB-ID: #VU62714

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21724

CWE-ID: CWE-665 - Improper Initialization

Exploit availability: No

Description

The vulnerability allows a remote attacker to escalate privileges on the system.

The vulnerability exists due to improper initialization in pgjdbc driver when handling attacker-controlled URL in connection properties as the driver does not verify if the class implements the expected interface before instantiating the class. A remote attacker can pass specially crafted URL to the affected application and execute arbitrary code in the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Postgresql JDBC Driver: 42.3.0 - 42.3.1, 42.2.0 - 42.2.24, 42.1.0 - 42.1.4, 42.0.0, 9.4.1207 - 9.4.1212


CPE2.3 External links

http://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-v7wg-cpwc-24m4
http://github.com/pgjdbc/pgjdbc/commit/f4d0ed69c0b3aae8531d83d6af4c57f22312c813
http://security.netapp.com/advisory/ntap-20220311-0005/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BVEO7BEFXPBVHSPYL3YKQWZI6DYXQLFS/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###