Denial of service in Vim



Published: 2022-05-09
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-1620
CWE-ID CWE-476
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Vim
Client/Desktop applications / Office applications

Vendor Vim.org

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) NULL pointer dereference

EUVDB-ID: #VU62876

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1620

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error within the vim_regexec_string() function in regexp.c. A remote attacker can trick the victim to open a specially crafted file, trigger NULL pointer dereference error and crash the application.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Vim: 8.2.4800 - 8.2.4899


CPE2.3 External links

http://huntr.dev/bounties/7a4c59f3-fcc0-4496-995d-5ca6acd2da51
http://github.com/vim/vim/commit/8e4b76da1d7e987d43ca960dfbc372d1c617466f

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###