Remote code execution in Microsoft Integration Runtime (Magnitude Simba Amazon Redshift ODBC Driver)



Published: 2022-05-09
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-29972
CWE-ID CWE-94
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
Microsoft Integration Runtime
Server applications / Other server solutions

Vendor Microsoft

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Code Injection

EUVDB-ID: #VU62879

Risk: Low

CVSSv3.1: 6.3 [CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-29972

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges within the application.

The vulnerability exists due to argument injection vulnerability in the browser-based authentication component of the Magnitude Simba Amazon Redshift ODBC Driver and involves improper validation of authentication tokens. A local user can escalate privileges within the affected application.

Mitigation

Install updates from Microsoft website.

Exploiting this vulnerability requires an attacker to have at least one of the following roles:

  • Synapse Administrator
  • Synapse Contributor
  • Synapse Compute Operator

Vulnerable software versions

Microsoft Integration Runtime: 1.0.5144.2 - 5.16.8105.2


CPE2.3 External links

http://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-29972
http://msrc.microsoft.com/update-guide/en-US/vulnerability/ADV220001

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###