Denial of service in Linux kernel KVM implementation



Published: 2022-05-13
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-1158
CWE-ID CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Linux kernel
Operating systems & Components / Operating system

Vendor Linux Foundation

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Out-of-bounds write

EUVDB-ID: #VU63166

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-1158

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due the KVM implementation in Linux kernel does not properly perform guest page table updates in some situations. A remote user on the guest operating system can trigger memory corruption and perform a denial of service attack against the host OS.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Linux kernel: All versions


CPE2.3 External links

http://seclists.org/oss-sec/2022/q2/22

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###