Privilege escalation in Nomad



Published: 2022-05-23
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-30324
CWE-ID CWE-264
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Nomad
Server applications / Virtualization software

Vendor HashiCorp

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Permissions, Privileges, and Access Controls

EUVDB-ID: #VU63504

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-30324

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote attacker to escalate privileges on the system.

The vulnerability exists due to application does not properly impose security restrictions in the go-getter library, which leads to security restrictions bypass and privilege escalation.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Nomad: 1.1.0 - 1.1.13, 1.2.0 - 1.2.7, 1.3.0


CPE2.3 External links

http://github.com/hashicorp/nomad/releases/tag/v1.3.1
http://github.com/hashicorp/nomad/releases/tag/v1.1.14
http://github.com/hashicorp/nomad/releases/tag/v1.2.8

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###