Red Hat Enterprise Linux update for Puppet Agent



Published: 2022-06-01
Risk Medium
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2021-27023
CVE-2021-27025
CWE-ID CWE-523
CWE-399
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Red Hat Enterprise Linux for x86_64 - Extended Update Support
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server - AUS
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server - TUS
Operating systems & Components / Operating system

Red Hat Enterprise Linux EUS Compute Node
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Power, little endian - Extended Update Support
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server - Extended Life Cycle Support
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Power 9
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Power, little endian
Operating systems & Components / Operating system

Red Hat Enterprise Linux for x86_64
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Scientific Computing
Operating systems & Components / Operating system

Red Hat Enterprise Linux Desktop
Operating systems & Components / Operating system

Red Hat Enterprise Linux Workstation
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server for x86_64 - Update Services for SAP Solutions
Operating systems & Components / Operating system package or component

puppet-agent (Red Hat package)
Operating systems & Components / Operating system package or component

Red Hat Enterprise Linux Server for Power LE - Update Services for SAP Solutions
Operating systems & Components / Operating system package or component

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Unprotected Transport of Credentials

EUVDB-ID: #VU62794

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-27023

CWE-ID: CWE-523 - Unprotected Transport of Credentials

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to application can leak HTTP credentials when following HTTP redirects to a different host. A remote attacker can gain access to sensitive information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for x86_64 - Extended Update Support: 7.6 - 8.6

Red Hat Enterprise Linux Server - AUS: 7.2 - 8.6

Red Hat Enterprise Linux Server for x86_64 - Update Services for SAP Solutions: 7.4 - 8.6

Red Hat Enterprise Linux Server - TUS: 7.4 - 8.6

puppet-agent (Red Hat package): 6.19.1-2.el7sat

Red Hat Enterprise Linux EUS Compute Node: 7.6 - 7.7

Red Hat Enterprise Linux Server for Power LE - Update Services for SAP Solutions: 7.4 - 7.7

Red Hat Enterprise Linux for Power, little endian - Extended Update Support: 7.6 - 7.7

Red Hat Enterprise Linux Server - Extended Life Cycle Support: 6.0

Red Hat Enterprise Linux for Power 9: 7.0

Red Hat Enterprise Linux for Power, little endian: 7

Red Hat Enterprise Linux for x86_64: 8.0

Red Hat Enterprise Linux for Scientific Computing: 7

Red Hat Enterprise Linux Desktop: 7

Red Hat Enterprise Linux Workstation: 7

Red Hat Enterprise Linux Server: 7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2022:4867

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Resource management error

EUVDB-ID: #VU62793

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-27025

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to the application silently ignore Augeas settings prior to the first pluginsync. A remote attacker can pass specially crafted data to the application and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for x86_64 - Extended Update Support: 7.6 - 8.6

Red Hat Enterprise Linux Server - AUS: 7.2 - 8.6

Red Hat Enterprise Linux Server for x86_64 - Update Services for SAP Solutions: 7.4 - 8.6

Red Hat Enterprise Linux Server - TUS: 7.4 - 8.6

puppet-agent (Red Hat package): 6.19.1-2.el7sat

Red Hat Enterprise Linux EUS Compute Node: 7.6 - 7.7

Red Hat Enterprise Linux Server for Power LE - Update Services for SAP Solutions: 7.4 - 7.7

Red Hat Enterprise Linux for Power, little endian - Extended Update Support: 7.6 - 7.7

Red Hat Enterprise Linux Server - Extended Life Cycle Support: 6.0

Red Hat Enterprise Linux for Power 9: 7.0

Red Hat Enterprise Linux for Power, little endian: 7

Red Hat Enterprise Linux for x86_64: 8.0

Red Hat Enterprise Linux for Scientific Computing: 7

Red Hat Enterprise Linux Desktop: 7

Red Hat Enterprise Linux Workstation: 7

Red Hat Enterprise Linux Server: 7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2022:4867

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###