Information disclosure in Cisco AppDynamics Controller



Published: 2022-06-16
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-20736
CWE-ID CWE-939
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Cisco AppDynamics Controller
Other software / Other software solutions

Vendor Cisco Systems, Inc

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Improper Authorization in Handler for Custom URL Scheme

EUVDB-ID: #VU64451

Risk: Medium

CVSSv3.1: 4.6 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-20736

CWE-ID: CWE-939 - Improper Authorization in Handler for Custom URL Scheme

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensntive information.

The vulnerability exists due to improper authorization checks in the web-based management interface. A remote attacker can send a specially crafted HTTP request and access the login page for an administrative console.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Cisco AppDynamics Controller: 21.4.6


CPE2.3 External links

http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-appd-contrl-athzn-bp-BLypgsbu

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###