SUSE update for the Linux Kernel



Published: 2022-06-16
Risk Low
Patch available YES
Number of vulnerabilities 29
CVE-ID CVE-2017-13695
CVE-2018-20784
CVE-2018-7755
CVE-2019-19377
CVE-2020-10769
CVE-2021-20292
CVE-2021-20321
CVE-2021-28688
CVE-2021-33061
CVE-2021-38208
CVE-2022-1011
CVE-2022-1184
CVE-2022-1353
CVE-2022-1419
CVE-2022-1516
CVE-2022-1652
CVE-2022-1729
CVE-2022-1734
CVE-2022-1974
CVE-2022-1975
CVE-2022-21123
CVE-2022-21125
CVE-2022-21127
CVE-2022-21166
CVE-2022-21180
CVE-2022-21499
CVE-2022-28388
CVE-2022-28390
CVE-2022-30594
CWE-ID CWE-200
CWE-400
CWE-264
CWE-416
CWE-125
CWE-362
CWE-665
CWE-20
CWE-476
CWE-248
CWE-459
CWE-284
CWE-415
CWE-276
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
SUSE Linux Enterprise Server
Operating systems & Components / Operating system

SUSE Linux Enterprise High Performance Computing
Operating systems & Components / Operating system

SUSE Linux Enterprise High Availability
Operating systems & Components / Operating system

SUSE OpenStack Cloud Crowbar
Operating systems & Components / Operating system

SUSE Linux Enterprise Server for SAP
Operating systems & Components / Operating system

HPE Helion Openstack
Operating systems & Components / Operating system

SUSE OpenStack Cloud
Operating systems & Components / Operating system

ocfs2-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

ocfs2-kmp-default
Operating systems & Components / Operating system package or component

gfs2-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

gfs2-kmp-default
Operating systems & Components / Operating system package or component

dlm-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

dlm-kmp-default
Operating systems & Components / Operating system package or component

cluster-md-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

cluster-md-kmp-default
Operating systems & Components / Operating system package or component

kernel-default-man
Operating systems & Components / Operating system package or component

kgraft-patch-4_4_180-94_164-default-debuginfo
Operating systems & Components / Operating system package or component

kgraft-patch-4_4_180-94_164-default
Operating systems & Components / Operating system package or component

kernel-syms
Operating systems & Components / Operating system package or component

kernel-default-kgraft
Operating systems & Components / Operating system package or component

kernel-default-devel
Operating systems & Components / Operating system package or component

kernel-default-debugsource
Operating systems & Components / Operating system package or component

kernel-default-debuginfo
Operating systems & Components / Operating system package or component

kernel-default-base-debuginfo
Operating systems & Components / Operating system package or component

kernel-default-base
Operating systems & Components / Operating system package or component

kernel-default
Operating systems & Components / Operating system package or component

kernel-source
Operating systems & Components / Operating system package or component

kernel-macros
Operating systems & Components / Operating system package or component

kernel-devel
Operating systems & Components / Operating system package or component

Vendor SuSE

Security Bulletin

This security bulletin contains information about 29 vulnerabilities.

1) Information disclosure

EUVDB-ID: #VU64436

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-13695

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows a local user to gain access to potentially sensitive information.

The vulnerability exists in the Linux kernel's ACPI subsystem where a function does not flush the operand cache and causes a kernel stack dump. A local user can pass a specially crafted ACPI table to obtain sensitive information from kernel memory and bypass the KASLR protection mechanism.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Resource exhaustion

EUVDB-ID: #VU17858

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-20784

CWE-ID: CWE-400 - Resource exhaustion

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to an error in resource management within the update_blocked_averages function in kernel/sched/fair.c when processing leaf cfs_rq's. A local user can cause resource exhaustion and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Security restrictions bypass

EUVDB-ID: #VU10918

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-7755

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a local unauthenticated attacker to bypass security restrictions on the target system.

The weakness exists in the drivers/block/floppy.c source code in the fd_locked_ioctl function due to insufficient security restrictions. A local attacker can bypass security restrictions through the system floppy drive and obtain kernel code and data from the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Use-after-free

EUVDB-ID: #VU28418

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-19377

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local non-authenticated attacker to execute arbitrary code.

In the Linux kernel 5.0.21, mounting a crafted btrfs filesystem image, performing some operations, and unmounting can lead to a use-after-free in btrfs_queue_work in fs/btrfs/async-thread.c.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Out-of-bounds read

EUVDB-ID: #VU50427

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2020-10769

CWE-ID: CWE-125 - Out-of-bounds read

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition within the crypto_authenc_extractkeys() function in crypto/authenc.c in the IPsec Cryptographic algorithm's module "authenc". A local low-privileged user can run a specially crafted program to trigger an out-of-bounds read error and crash the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Use-after-free

EUVDB-ID: #VU63382

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-20292

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges.

The vulnerability exists due to a use-after-free error in drivers/gpu/drm/nouveau/nouveau_sgdma.c in nouveau_sgdma_create_ttm in Nouveau DRM subsystem. A local user can escalate privileges and execute code in the context of the kernel.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Race condition

EUVDB-ID: #VU59084

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-20321

CWE-ID: CWE-362 - Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attacks.

The vulnerability exists due to a race condition when accessing file object in the Linux kernel OverlayFS subsystem. A local user can rename files in specific way with OverlayFS and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Improper Initialization

EUVDB-ID: #VU63658

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-28688

CWE-ID: CWE-665 - Improper Initialization

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service attack.

The vulnerability exists due to improper initialization of pointers such that subsequent cleanup code wouldn't use uninitialized or stale values. A local user can perform a denial of service attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

9) Input validation error

EUVDB-ID: #VU60490

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-33061

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient control flow management. A local user can pass specially crafted input to the application and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

10) NULL pointer dereference

EUVDB-ID: #VU63383

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-38208

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in the net/nfc/llcp_sock.c component. A remote attacker can make getsockname call and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

11) Use-after-free

EUVDB-ID: #VU63386

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1011

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the write() function of FUSE filesystem. A local user can retireve (partial) /etc/shadow hashes and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

12) Use-after-free

EUVDB-ID: #VU64438

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1184

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service attack.

The vulnerability exists due to a use-after-free error in fs/ext4/namei.c:dx_insert_block() function in the Linux kernel’s filesystem sub-component.. A local user can trigger use-after-free and perform a denial of service attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

13) Information disclosure

EUVDB-ID: #VU63388

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1353

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows a local user to gain access to potentially sensitive information.

The vulnerability exists due to excessive data output by the application in the pfkey_register function in net/key/af_key.c in the Linux kernel. A local user can gain unauthorized access to kernel memory, leading to a system crash or a leak of internal kernel information.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

14) Use-after-free

EUVDB-ID: #VU63418

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1419

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in vgem_gem_dumb_create() function in Linux kernel. A local user can trigger a use-after-free error and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

15) NULL pointer dereference

EUVDB-ID: #VU63158

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1516

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to NULL pointer dereference error in the Linux kernel’s X.25 set of standardized network protocols functionality. A local user can terminate session using a simulated Ethernet card and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

16) Use-after-free

EUVDB-ID: #VU64434

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1652

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to use-after-free error in the bad_flp_intr() function. A local user can execute a specially-crafted program to cause a denial of service condition on the system or escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

17) Race condition

EUVDB-ID: #VU64156

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1729

CWE-ID: CWE-362 - Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a race condition within sys_perf_event_open() in Linux kernel. A local user can exploit the race and gain unauthorized access to sensitive information and escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

18) Use-after-free

EUVDB-ID: #VU64082

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1734

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to Marvell NFC device driver implementation in the Linux kernel did not properly perform memory cleanup operations in some situations. A local user can trigger use-after-free to escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

19) Use-after-free

EUVDB-ID: #VU64263

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1974

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local privileged user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the Linux kernel's NFC core functionality due to a race condition between kobject creation and delete. A local attacker with CAP_NET_ADMIN privilege can leak kernel information and escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

20) Uncaught Exception

EUVDB-ID: #VU64264

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1975

CWE-ID: CWE-248 - Uncaught Exception

Exploit availability: No

Description

The vulnerability allows a remote attacker on the local network to perform a denial of service (DoS) attack.

The vulnerability exists due to an uncaught exception error in the Linux kernel. A remote attacker on the local network can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

21) Information disclosure

EUVDB-ID: #VU64364

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21123

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists in Intel processors due to excessive data output when DirectPath I/O (PCI-Passthrough) is utilized. An attacker (both local and remote) with administrative access to a virtual machine that has an attached DirectPath I/O (PCI-Passthrough) device can obtain information stored in physical memory about the hypervisor or other virtual machines that reside on the same host.


Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

22) Information disclosure

EUVDB-ID: #VU64365

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21125

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists in Intel processors due to excessive data output when DirectPath I/O (PCI-Passthrough) is utilized. An attacker (both local and remote) with administrative access to a virtual machine that has an attached DirectPath I/O (PCI-Passthrough) device can obtain information stored in physical memory about the hypervisor or other virtual machines that reside on the same host.



Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

23) Incomplete cleanup

EUVDB-ID: #VU64376

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21127

CWE-ID: CWE-459 - Incomplete cleanup

Exploit availability: No

Description

The vulnerability allows a local user to gain access to sensitive information on the system.

The vulnerability exists due to incomplete cleanup in specific special register read operations. A local user can enable information disclosure.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

24) Information disclosure

EUVDB-ID: #VU64366

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21166

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists in Intel processors due to excessive data output when DirectPath I/O (PCI-Passthrough) is utilized. An attacker (both local and remote) with administrative access to a virtual machine that has an attached DirectPath I/O (PCI-Passthrough) device can obtain information stored in physical memory about the hypervisor or other virtual machines that reside on the same host.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

25) Input validation error

EUVDB-ID: #VU64377

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21180

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation in Memory Mapped I/O (MMIO) for some 14nm Client/Xeon E3 Intel® Processors. A local user can pass specially crafted input and perform a denial of service (DoS) attack in certain virtualized environments.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

26) Improper access control

EUVDB-ID: #VU63961

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21499

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a local user to bypass implemented security restrictions.

The vulnerability exists due to improper access restrictions to the kernel debugger when booted in secure boot environments. A local privileged user can bypass UEFI Secure Boot restrictions.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

27) Double Free

EUVDB-ID: #VU63160

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-28388

CWE-ID: CWE-415 - Double Free

Exploit availability: No

Description

The vulnerability allows a local user to execute arbitrary code with elevated privileges.

The vulnerability exists due to boundary error in the usb_8dev_start_xmit in drivers/net/can/usb/usb_8dev.c. A local user can pass specially crafted data to the application, trigger double free error and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

28) Double Free

EUVDB-ID: #VU63164

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-28390

CWE-ID: CWE-415 - Double Free

Exploit availability: No

Description

The vulnerability allows a local user to execute arbitrary code with elevated privileges.

The vulnerability exists due to boundary error in ems_usb_start_xmit in drivers/net/can/usb/ems_usb.c. A local user can pass specially crafted data to the application, trigger double free error and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

29) Incorrect default permissions

EUVDB-ID: #VU63631

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-30594

CWE-ID: CWE-276 - Incorrect Default Permissions

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to mishandling seccomp permissions. A local user can bypass intended restrictions on setting the PT_SUSPEND_SECCOMP flag and escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Server: 12-SP3 - 12-SP3-LTSS

SUSE Linux Enterprise High Performance Computing: 12-SP3

SUSE Linux Enterprise High Availability: 12-SP3

SUSE OpenStack Cloud Crowbar: 8

SUSE Linux Enterprise Server for SAP: 12-SP3

HPE Helion Openstack: 8

SUSE OpenStack Cloud: 8

ocfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

ocfs2-kmp-default: before 4.4.180-94.164.3

gfs2-kmp-default-debuginfo: before 4.4.180-94.164.3

gfs2-kmp-default: before 4.4.180-94.164.3

dlm-kmp-default-debuginfo: before 4.4.180-94.164.3

dlm-kmp-default: before 4.4.180-94.164.3

cluster-md-kmp-default-debuginfo: before 4.4.180-94.164.3

cluster-md-kmp-default: before 4.4.180-94.164.3

kernel-default-man: before 4.4.180-94.164.3

kgraft-patch-4_4_180-94_164-default-debuginfo: before 1-4.3.2

kgraft-patch-4_4_180-94_164-default: before 1-4.3.2

kernel-syms: before 4.4.180-94.164.2

kernel-default-kgraft: before 4.4.180-94.164.3

kernel-default-devel: before 4.4.180-94.164.3

kernel-default-debugsource: before 4.4.180-94.164.3

kernel-default-debuginfo: before 4.4.180-94.164.3

kernel-default-base-debuginfo: before 4.4.180-94.164.3

kernel-default-base: before 4.4.180-94.164.3

kernel-default: before 4.4.180-94.164.3

kernel-source: before 4.4.180-94.164.2

kernel-macros: before 4.4.180-94.164.2

kernel-devel: before 4.4.180-94.164.2


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222082-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###