SUSE update for the Linux Kernel



Published: 2022-06-17
Risk Medium
Patch available YES
Number of vulnerabilities 23
CVE-ID CVE-2019-19377
CVE-2020-26541
CVE-2021-20321
CVE-2021-33061
CVE-2022-0168
CVE-2022-1011
CVE-2022-1158
CVE-2022-1184
CVE-2022-1353
CVE-2022-1516
CVE-2022-1652
CVE-2022-1729
CVE-2022-1734
CVE-2022-1966
CVE-2022-1974
CVE-2022-1975
CVE-2022-21123
CVE-2022-21125
CVE-2022-21127
CVE-2022-21166
CVE-2022-21180
CVE-2022-28893
CVE-2022-30594
CWE-ID CWE-416
CWE-693
CWE-362
CWE-20
CWE-476
CWE-787
CWE-200
CWE-248
CWE-459
CWE-276
Exploitation vector Network
Public exploit Public exploit code for vulnerability #14 is available.
Vulnerable software
Subscribe
SUSE Linux Enterprise High Availability
Operating systems & Components / Operating system

SUSE Linux Enterprise Server for SAP Applications
Operating systems & Components / Operating system

SUSE Linux Enterprise Server
Operating systems & Components / Operating system

SUSE Linux Enterprise Module for Live Patching
Operating systems & Components / Operating system

SUSE Linux Enterprise High Performance Computing
Operating systems & Components / Operating system

SUSE Manager Server
Operating systems & Components / Operating system

SUSE Manager Retail Branch Server
Operating systems & Components / Operating system

SUSE Manager Proxy
Operating systems & Components / Operating system

SUSE Linux Enterprise Server for SAP
Operating systems & Components / Operating system

SUSE Enterprise Storage
Operating systems & Components / Operating system

ocfs2-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

ocfs2-kmp-default
Operating systems & Components / Operating system package or component

gfs2-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

gfs2-kmp-default
Operating systems & Components / Operating system package or component

dlm-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

dlm-kmp-default
Operating systems & Components / Operating system package or component

cluster-md-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

cluster-md-kmp-default
Operating systems & Components / Operating system package or component

kernel-livepatch-SLE15-SP2_Update_27-debugsource
Operating systems & Components / Operating system package or component

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo
Operating systems & Components / Operating system package or component

kernel-livepatch-5_3_18-150200_24_115-default
Operating systems & Components / Operating system package or component

kernel-default-livepatch-devel
Operating systems & Components / Operating system package or component

kernel-default-livepatch
Operating systems & Components / Operating system package or component

kernel-source
Operating systems & Components / Operating system package or component

kernel-macros
Operating systems & Components / Operating system package or component

kernel-docs
Operating systems & Components / Operating system package or component

kernel-devel
Operating systems & Components / Operating system package or component

kernel-preempt-devel-debuginfo
Operating systems & Components / Operating system package or component

kernel-preempt-devel
Operating systems & Components / Operating system package or component

kernel-preempt-debugsource
Operating systems & Components / Operating system package or component

kernel-preempt-debuginfo
Operating systems & Components / Operating system package or component

kernel-preempt
Operating systems & Components / Operating system package or component

reiserfs-kmp-default-debuginfo
Operating systems & Components / Operating system package or component

reiserfs-kmp-default
Operating systems & Components / Operating system package or component

kernel-syms
Operating systems & Components / Operating system package or component

kernel-obs-build-debugsource
Operating systems & Components / Operating system package or component

kernel-obs-build
Operating systems & Components / Operating system package or component

kernel-default-devel-debuginfo
Operating systems & Components / Operating system package or component

kernel-default-devel
Operating systems & Components / Operating system package or component

kernel-default-debugsource
Operating systems & Components / Operating system package or component

kernel-default-debuginfo
Operating systems & Components / Operating system package or component

kernel-default-base
Operating systems & Components / Operating system package or component

kernel-default
Operating systems & Components / Operating system package or component

Vendor SuSE

Security Bulletin

This security bulletin contains information about 23 vulnerabilities.

1) Use-after-free

EUVDB-ID: #VU28418

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-19377

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local non-authenticated attacker to execute arbitrary code.

In the Linux kernel 5.0.21, mounting a crafted btrfs filesystem image, performing some operations, and unmounting can lead to a use-after-free in btrfs_queue_work in fs/btrfs/async-thread.c.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Protection Mechanism Failure

EUVDB-ID: #VU54455

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2020-26541

CWE-ID: CWE-693 - Protection Mechanism Failure

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The Linux kernel through 5.8.13 does not properly enforce the Secure Boot Forbidden Signature Database (aka dbx) protection mechanism. This affects certs/blacklist.c and certs/system_keyring.c. A local user can escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Race condition

EUVDB-ID: #VU59084

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-20321

CWE-ID: CWE-362 - Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attacks.

The vulnerability exists due to a race condition when accessing file object in the Linux kernel OverlayFS subsystem. A local user can rename files in specific way with OverlayFS and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Input validation error

EUVDB-ID: #VU60490

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-33061

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient control flow management. A local user can pass specially crafted input to the application and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) NULL pointer dereference

EUVDB-ID: #VU63789

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-0168

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in the Linux kernel’s smb2_ioctl_query_info function in the fs/cifs/smb2ops.c Common Internet File System (CIFS). A privileged (CAP_SYS_ADMIN) attacker can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Use-after-free

EUVDB-ID: #VU63386

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1011

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the write() function of FUSE filesystem. A local user can retireve (partial) /etc/shadow hashes and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Out-of-bounds write

EUVDB-ID: #VU63166

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-1158

CWE-ID: CWE-787 - Out-of-bounds write

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due the KVM implementation in Linux kernel does not properly perform guest page table updates in some situations. A remote user on the guest operating system can trigger memory corruption and perform a denial of service attack against the host OS.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Use-after-free

EUVDB-ID: #VU64438

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1184

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service attack.

The vulnerability exists due to a use-after-free error in fs/ext4/namei.c:dx_insert_block() function in the Linux kernel’s filesystem sub-component.. A local user can trigger use-after-free and perform a denial of service attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

9) Information disclosure

EUVDB-ID: #VU63388

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1353

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows a local user to gain access to potentially sensitive information.

The vulnerability exists due to excessive data output by the application in the pfkey_register function in net/key/af_key.c in the Linux kernel. A local user can gain unauthorized access to kernel memory, leading to a system crash or a leak of internal kernel information.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

10) NULL pointer dereference

EUVDB-ID: #VU63158

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1516

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to NULL pointer dereference error in the Linux kernel’s X.25 set of standardized network protocols functionality. A local user can terminate session using a simulated Ethernet card and perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

11) Use-after-free

EUVDB-ID: #VU64434

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1652

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to use-after-free error in the bad_flp_intr() function. A local user can execute a specially-crafted program to cause a denial of service condition on the system or escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

12) Race condition

EUVDB-ID: #VU64156

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1729

CWE-ID: CWE-362 - Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a race condition within sys_perf_event_open() in Linux kernel. A local user can exploit the race and gain unauthorized access to sensitive information and escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

13) Use-after-free

EUVDB-ID: #VU64082

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1734

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to Marvell NFC device driver implementation in the Linux kernel did not properly perform memory cleanup operations in some situations. A local user can trigger use-after-free to escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

14) Use-after-free

EUVDB-ID: #VU64070

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1966

CWE-ID: CWE-416 - Use After Free

Exploit availability: Yes

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the Linux kernel's Netfilter subsystem in net/netfilter/nf_tables_api.c. A local user can trigger use-after-free error to escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

15) Use-after-free

EUVDB-ID: #VU64263

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1974

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local privileged user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the Linux kernel's NFC core functionality due to a race condition between kobject creation and delete. A local attacker with CAP_NET_ADMIN privilege can leak kernel information and escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

16) Uncaught Exception

EUVDB-ID: #VU64264

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1975

CWE-ID: CWE-248 - Uncaught Exception

Exploit availability: No

Description

The vulnerability allows a remote attacker on the local network to perform a denial of service (DoS) attack.

The vulnerability exists due to an uncaught exception error in the Linux kernel. A remote attacker on the local network can perform a denial of service (DoS) attack.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

17) Information disclosure

EUVDB-ID: #VU64364

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21123

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists in Intel processors due to excessive data output when DirectPath I/O (PCI-Passthrough) is utilized. An attacker (both local and remote) with administrative access to a virtual machine that has an attached DirectPath I/O (PCI-Passthrough) device can obtain information stored in physical memory about the hypervisor or other virtual machines that reside on the same host.


Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

18) Information disclosure

EUVDB-ID: #VU64365

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21125

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists in Intel processors due to excessive data output when DirectPath I/O (PCI-Passthrough) is utilized. An attacker (both local and remote) with administrative access to a virtual machine that has an attached DirectPath I/O (PCI-Passthrough) device can obtain information stored in physical memory about the hypervisor or other virtual machines that reside on the same host.



Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

19) Incomplete cleanup

EUVDB-ID: #VU64376

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21127

CWE-ID: CWE-459 - Incomplete cleanup

Exploit availability: No

Description

The vulnerability allows a local user to gain access to sensitive information on the system.

The vulnerability exists due to incomplete cleanup in specific special register read operations. A local user can enable information disclosure.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

20) Information disclosure

EUVDB-ID: #VU64366

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21166

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows an attacker to gain access to potentially sensitive information.

The vulnerability exists in Intel processors due to excessive data output when DirectPath I/O (PCI-Passthrough) is utilized. An attacker (both local and remote) with administrative access to a virtual machine that has an attached DirectPath I/O (PCI-Passthrough) device can obtain information stored in physical memory about the hypervisor or other virtual machines that reside on the same host.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

21) Input validation error

EUVDB-ID: #VU64377

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21180

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation in Memory Mapped I/O (MMIO) for some 14nm Client/Xeon E3 Intel® Processors. A local user can pass specially crafted input and perform a denial of service (DoS) attack in certain virtualized environments.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

22) Use-after-free

EUVDB-ID: #VU62074

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-28893

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error within the SUNRPC subsystem in the Linux kernel. A local user can trigger a use-after-free error and execute arbitrary code with elevated privileges.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

23) Incorrect default permissions

EUVDB-ID: #VU63631

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-30594

CWE-ID: CWE-276 - Incorrect Default Permissions

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to mishandling seccomp permissions. A local user can bypass intended restrictions on setting the PT_SUSPEND_SECCOMP flag and escalate privileges on the system.

Mitigation

Update the affected package the Linux Kernel to the latest version.

Vulnerable software versions

SUSE Linux Enterprise High Availability: 15-SP2

SUSE Linux Enterprise Server for SAP Applications: 15-SP2

SUSE Linux Enterprise Server: 15-SP2 - 15-SP2-LTSS

SUSE Linux Enterprise Module for Live Patching: 15-SP2

SUSE Linux Enterprise High Performance Computing: 15-SP2 - 15-SP2-LTSS

SUSE Manager Server: 4.1

SUSE Manager Retail Branch Server: 4.1

SUSE Manager Proxy: 4.1

SUSE Linux Enterprise Server for SAP: 15-SP2

SUSE Enterprise Storage: 7

ocfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

ocfs2-kmp-default: before 5.3.18-150200.24.115.1

gfs2-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

gfs2-kmp-default: before 5.3.18-150200.24.115.1

dlm-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

dlm-kmp-default: before 5.3.18-150200.24.115.1

cluster-md-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

cluster-md-kmp-default: before 5.3.18-150200.24.115.1

kernel-livepatch-SLE15-SP2_Update_27-debugsource: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default-debuginfo: before 1-150200.5.3.1

kernel-livepatch-5_3_18-150200_24_115-default: before 1-150200.5.3.1

kernel-default-livepatch-devel: before 5.3.18-150200.24.115.1

kernel-default-livepatch: before 5.3.18-150200.24.115.1

kernel-source: before 5.3.18-150200.24.115.1

kernel-macros: before 5.3.18-150200.24.115.1

kernel-docs: before 5.3.18-150200.24.115.1

kernel-devel: before 5.3.18-150200.24.115.1

kernel-preempt-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt-devel: before 5.3.18-150200.24.115.1

kernel-preempt-debugsource: before 5.3.18-150200.24.115.1

kernel-preempt-debuginfo: before 5.3.18-150200.24.115.1

kernel-preempt: before 5.3.18-150200.24.115.1

reiserfs-kmp-default-debuginfo: before 5.3.18-150200.24.115.1

reiserfs-kmp-default: before 5.3.18-150200.24.115.1

kernel-syms: before 5.3.18-150200.24.115.1

kernel-obs-build-debugsource: before 5.3.18-150200.24.115.1

kernel-obs-build: before 5.3.18-150200.24.115.1

kernel-default-devel-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-devel: before 5.3.18-150200.24.115.1

kernel-default-debugsource: before 5.3.18-150200.24.115.1

kernel-default-debuginfo: before 5.3.18-150200.24.115.1

kernel-default-base: before 5.3.18-150200.24.115.1.150200.9.54.1

kernel-default: before 5.3.18-150200.24.115.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222104-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###