Remote code execution in XFCE exo



Published: 2022-06-20
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-32278
CWE-ID CWE-254
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
exo
Universal components / Libraries / Libraries used by multiple products

Vendor xfce-mirror

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Security features bypass

EUVDB-ID: #VU64516

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-32278

CWE-ID: CWE-254 - Security Features

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the affected system.

The vulnerability exists due to xdg-open can execute a ".desktop" file on an attacker-controlled FTP server. A remote attacker can trick the victim into opening a malicious desktop file and execute arbitrary code on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

exo: 0.1.1 - 4.17.1


CPE2.3 External links

http://gitlab.xfce.org/xfce/exo/-/commit/c71c04ff5882b2866a0d8506fb460d4ef796de9f
http://www.debian.org/security/2022/dsa-5164

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###