Privilege escalation in BIG-IQ Centralized Management (Linux kernel component)



Published: 2022-07-11
Risk Low
Patch available NO
Number of vulnerabilities 1
CVE-ID CVE-2021-22555
CWE-ID CWE-787
Exploitation vector Local
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
BIG-IQ Centralized Management
Server applications / Remote management servers, RDP, SSH

Vendor F5 Networks, Inc.

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Out-of-bounds write

EUVDB-ID: #VU56017

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-22555

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: Yes

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a boundary error when processing untrusted input in net/netfilter/x_tables.c in Linux kernel. A local user can run a specially crafted program to trigger an out-of-bounds write and execute arbitrary code with elevated privileges.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

BIG-IQ Centralized Management: 7.0.0 - 8.2.0


CPE2.3 External links

http://support.f5.com/csp/article/K06524534

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###