Ubuntu update for webkit2gtk



Published: 2022-07-18
Risk High
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2022-22677
CVE-2022-26710
CWE-ID CWE-399
CWE-416
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Ubuntu
Operating systems & Components / Operating system

libjavascriptcoregtk-4.0-18 (Ubuntu package)
Operating systems & Components / Operating system package or component

libwebkit2gtk-4.0-37 (Ubuntu package)
Operating systems & Components / Operating system package or component

libwebkit2gtk-4.1-0 (Ubuntu package)
/

libjavascriptcoregtk-4.1-0 (Ubuntu package)
/

Vendor Canonical Ltd.

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Resource management error

EUVDB-ID: #VU63285

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-22677

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform DoS attack.

The vulnerability exists due to a logic issue in video self-preview feature in a webRTC call, which can be interrupted if the user answers a phone call.

Mitigation

Update the affected package webkit2gtk to the latest version.

Vulnerable software versions

Ubuntu: 22.04, 20.04

libjavascriptcoregtk-4.0-18 (Ubuntu package): before 2.36.4-0ubuntu0.20.04.1

libwebkit2gtk-4.1-0 (Ubuntu package): before 2.36.4-0ubuntu0.22.04.1

libwebkit2gtk-4.0-37 (Ubuntu package): before 2.36.4-0ubuntu0.20.04.1

libjavascriptcoregtk-4.1-0 (Ubuntu package): before 2.36.4-0ubuntu0.22.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5522-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Use-after-free

EUVDB-ID: #VU63281

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-26710

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error when processing HTML content in WebKit. A remote attacker can trick the victim to visit a specially crafted website, trigger memory corruption and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Update the affected package webkit2gtk to the latest version.

Vulnerable software versions

Ubuntu: 22.04, 20.04

libjavascriptcoregtk-4.0-18 (Ubuntu package): before 2.36.4-0ubuntu0.20.04.1

libwebkit2gtk-4.1-0 (Ubuntu package): before 2.36.4-0ubuntu0.22.04.1

libwebkit2gtk-4.0-37 (Ubuntu package): before 2.36.4-0ubuntu0.20.04.1

libjavascriptcoregtk-4.1-0 (Ubuntu package): before 2.36.4-0ubuntu0.22.04.1


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5522-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###