Multiple vulnerabilities in Moodle



Published: 2022-07-19
Risk Medium
Patch available YES
Number of vulnerabilities 4
CVE-ID CVE-2022-35653
CVE-2022-35650
CVE-2022-35651
CVE-2022-35652
CWE-ID CWE-79
CWE-22
CWE-601
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Moodle
Web applications / Other software

Vendor moodle.org

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) Cross-site scripting

EUVDB-ID: #VU65403

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-35653

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Moodle: 3.9.0 - 3.9.14, 3.11 - 3.11.7, 4.0.0 - 4.0.1


CPE2.3 External links

http://moodle.org/mod/forum/discuss.php?d=436460

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Path traversal

EUVDB-ID: #VU65407

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-35650

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to input validation error when importing lesson questions. A remote user can send a specially crafted HTTP request and read arbitrary files on the system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Moodle: 3.9.0 - 3.9.14, 3.11 - 3.11.7, 4.0.0 - 4.0.1


CPE2.3 External links

http://moodle.org/mod/forum/discuss.php?d=436457

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Stored cross-site scripting

EUVDB-ID: #VU65405

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-35651

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data in the SCORM track details. A remote attacker can inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Moodle: 3.9.0 - 3.9.14, 3.11 - 3.11.7, 4.0.0 - 4.0.1


CPE2.3 External links

http://moodle.org/mod/forum/discuss.php?d=436458

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Open redirect

EUVDB-ID: #VU65404

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-35652

CWE-ID: CWE-601 - URL Redirection to Untrusted Site ('Open Redirect')

Exploit availability: No

Description

The vulnerability allows a remote attacker to redirect victims to arbitrary URL.

The vulnerability exists due to improper sanitization of user-supplied data in mobile auto-login feature. A remote attacker can create a link that leads to a trusted website, however, when clicked, redirects the victim to arbitrary domain.

Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Moodle: 3.9.0 - 3.9.14, 3.11 - 3.11.7, 4.0.0 - 4.0.1


CPE2.3 External links

http://moodle.org/mod/forum/discuss.php?d=436459

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###