Multiple vulnerabilities in Oracle Communications Cloud Native Core Network Repository Function



Published: 2022-07-19 | Updated: 2023-02-01
Risk High
Patch available YES
Number of vulnerabilities 5
CVE-ID CVE-2022-23308
CVE-2020-36518
CVE-2021-22119
CVE-2022-23219
CVE-2022-22947
CWE-ID CWE-416
CWE-787
CWE-20
CWE-119
CWE-94
Exploitation vector Network
Public exploit Public exploit code for vulnerability #3 is available.
Vulnerability #5 is being exploited in the wild.
Vulnerable software
Subscribe
Oracle Communications Cloud Native Core Network Repository Function
Server applications / Other server solutions

Vendor Oracle

Security Bulletin

This security bulletin contains information about 5 vulnerabilities.

1) Use-after-free

EUVDB-ID: #VU60922

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-23308

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error when processing ID and IDREF attributes in valid.c. A remote attacker can pass specially crafted XML input to the application, trigger a use-after-free error and crash the application or execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Repository Function: 22.1.2 - 22.2.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujul2022.html?947626

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Out-of-bounds write

EUVDB-ID: #VU61799

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-36518

CWE-ID: CWE-787 - Out-of-bounds write

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error when processing untrusted input. A remote attacker can trigger out-of-bounds write and cause a denial of service condition on the target system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Repository Function: 22.1.2 - 22.2.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujul2022.html?947626

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Improper input validation

EUVDB-ID: #VU60091

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-22119

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: Yes

Description

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper input validation within the Policy (Spring Security) component in Oracle Communications Cloud Native Core Policy. A remote non-authenticated attacker can exploit this vulnerability to perform a denial of service (DoS) attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Repository Function: 22.1.2 - 22.2.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujul2022.html?947626

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Buffer overflow

EUVDB-ID: #VU61295

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-23219

CWE-ID: CWE-119 - Memory corruption

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error within the clnt_create() function in the sunrpc module. A remote attacker can pass specially crafted input to the application that is using the affected library version, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Repository Function: 22.1.2 - 22.2.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujul2022.html?947626

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Code Injection

EUVDB-ID: #VU60982

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-22947

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: Yes

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a code injection attack when the Gateway Actuator endpoint is enabled. A remote attacker can send a specially crafted HTTP POST request and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Oracle Communications Cloud Native Core Network Repository Function: 22.1.2 - 22.2.0


CPE2.3 External links

http://www.oracle.com/security-alerts/cpujul2022.html?947626

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###