SUSE update for java-1_7_1-ibm



Published: 2022-07-25 | Updated: 2022-08-22
Risk Medium
Patch available YES
Number of vulnerabilities 8
CVE-ID CVE-2021-35561
CVE-2022-21299
CVE-2022-21426
CVE-2022-21434
CVE-2022-21443
CVE-2022-21449
CVE-2022-21476
CVE-2022-21496
CWE-ID CWE-20
Exploitation vector Network
Public exploit Public exploit code for vulnerability #6 is available.
Vulnerable software
Subscribe
SUSE OpenStack Cloud Crowbar
Operating systems & Components / Operating system

SUSE Linux Enterprise Software Development Kit
Operating systems & Components / Operating system

SUSE Linux Enterprise Server for SAP
Operating systems & Components / Operating system

SUSE Linux Enterprise Server for SAP Applications
Operating systems & Components / Operating system

SUSE Linux Enterprise Server
Operating systems & Components / Operating system

SUSE OpenStack Cloud
Server applications / Other server solutions

java-1_7_1-ibm-plugin
Operating systems & Components / Operating system package or component

java-1_7_1-ibm-jdbc
Operating systems & Components / Operating system package or component

java-1_7_1-ibm-devel
Operating systems & Components / Operating system package or component

java-1_7_1-ibm-alsa
Operating systems & Components / Operating system package or component

java-1_7_1-ibm
Operating systems & Components / Operating system package or component

Vendor SuSE

Security Bulletin

This security bulletin contains information about 8 vulnerabilities.

1) Improper input validation

EUVDB-ID: #VU57493

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-35561

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the Utility component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Improper input validation

EUVDB-ID: #VU59727

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21299

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the JAXP component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Improper input validation

EUVDB-ID: #VU62399

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21426

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the JAXP component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Improper input validation

EUVDB-ID: #VU62401

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21434

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Improper input validation

EUVDB-ID: #VU62402

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21443

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Improper input validation

EUVDB-ID: #VU62397

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21449

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: Yes

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Improper input validation

EUVDB-ID: #VU62398

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21476

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to gain access to sensitive information.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Improper input validation

EUVDB-ID: #VU62400

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21496

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the JNDI component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Update the affected package java-1_7_1-ibm to the latest version.

Vulnerable software versions

SUSE OpenStack Cloud Crowbar: 9

SUSE Linux Enterprise Software Development Kit: 12-SP5

SUSE Linux Enterprise Server for SAP: 12-SP4

SUSE Linux Enterprise Server for SAP Applications: 12-SP5

SUSE Linux Enterprise Server: 12-SP2-BCL - 12-SP5

SUSE OpenStack Cloud: 9

java-1_7_1-ibm-plugin: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-jdbc: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-devel: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm-alsa: before 1.7.1_sr5.10-38.71.1

java-1_7_1-ibm: before 1.7.1_sr5.10-38.71.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20222539-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###