Denial of service in Foxit Reader for Linux



Published: 2022-08-05
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2019-7317
CWE-ID CWE-416
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Foxit Reader for Linux
Client/Desktop applications / Office applications

Vendor Foxit Software Inc.

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Use-after-free

EUVDB-ID: #VU17708

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-7317

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to cause DoS condition.

The vulnerability exists due to a use-after-free memory error in the png_image_free function, as defined in the png.c source code file when calling on png_safe_execute. A remote attacker can send specially crafted data, trigger a call on png_safe_execute and trigger memory corruption, resulting in a DoS condition.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Foxit Reader for Linux: 2.4.4.0910


CPE2.3 External links

http://www.foxitsoftware.com/support/security-bulletins.html?Security+update+available+in+Foxit+Reader+for+Linux+2.4.52022-08-02+00%3A00%3A00

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###