Amazon Linux AMI update for clamav



Published: 2022-08-06
Risk Medium
Patch available YES
Number of vulnerabilities 4
CVE-ID CVE-2022-20770
CVE-2022-20771
CVE-2022-20785
CVE-2022-20796
CWE-ID CWE-835
CWE-401
CWE-476
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Amazon Linux AMI
Operating systems & Components / Operating system

clamav
Operating systems & Components / Operating system package or component

Vendor Amazon Web Services

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) Infinite loop

EUVDB-ID: #VU62800

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-20770

CWE-ID: CWE-835 - Loop with Unreachable Exit Condition ('Infinite Loop')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to infinite loop in the CHM file parser. A remote attacker can consume all available system resources and cause denial of service conditions.

Mitigation

Update the affected packages:

i686:
    clamav-0.103.6-1.49.amzn1.i686
    clamav-db-0.103.6-1.49.amzn1.i686
    clamav-lib-0.103.6-1.49.amzn1.i686
    clamav-debuginfo-0.103.6-1.49.amzn1.i686
    clamav-devel-0.103.6-1.49.amzn1.i686
    clamav-update-0.103.6-1.49.amzn1.i686
    clamav-milter-0.103.6-1.49.amzn1.i686
    clamd-0.103.6-1.49.amzn1.i686

noarch:
    clamav-filesystem-0.103.6-1.49.amzn1.noarch
    clamav-data-0.103.6-1.49.amzn1.noarch

src:
    clamav-0.103.6-1.49.amzn1.src

x86_64:
    clamav-milter-0.103.6-1.49.amzn1.x86_64
    clamav-update-0.103.6-1.49.amzn1.x86_64
    clamd-0.103.6-1.49.amzn1.x86_64
    clamav-0.103.6-1.49.amzn1.x86_64
    clamav-db-0.103.6-1.49.amzn1.x86_64
    clamav-debuginfo-0.103.6-1.49.amzn1.x86_64
    clamav-devel-0.103.6-1.49.amzn1.x86_64
    clamav-lib-0.103.6-1.49.amzn1.x86_64

Vulnerable software versions

Amazon Linux AMI: All versions

clamav: before 0.103.6-1.49


CPE2.3 External links

http://alas.aws.amazon.com/ALAS-2022-1621.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Infinite loop

EUVDB-ID: #VU62802

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-20771

CWE-ID: CWE-835 - Loop with Unreachable Exit Condition ('Infinite Loop')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to infinite loop in the TIFF file parser. A remote attacker can consume all available system resources and cause denial of service conditions.

Mitigation

Update the affected packages:

i686:
    clamav-0.103.6-1.49.amzn1.i686
    clamav-db-0.103.6-1.49.amzn1.i686
    clamav-lib-0.103.6-1.49.amzn1.i686
    clamav-debuginfo-0.103.6-1.49.amzn1.i686
    clamav-devel-0.103.6-1.49.amzn1.i686
    clamav-update-0.103.6-1.49.amzn1.i686
    clamav-milter-0.103.6-1.49.amzn1.i686
    clamd-0.103.6-1.49.amzn1.i686

noarch:
    clamav-filesystem-0.103.6-1.49.amzn1.noarch
    clamav-data-0.103.6-1.49.amzn1.noarch

src:
    clamav-0.103.6-1.49.amzn1.src

x86_64:
    clamav-milter-0.103.6-1.49.amzn1.x86_64
    clamav-update-0.103.6-1.49.amzn1.x86_64
    clamd-0.103.6-1.49.amzn1.x86_64
    clamav-0.103.6-1.49.amzn1.x86_64
    clamav-db-0.103.6-1.49.amzn1.x86_64
    clamav-debuginfo-0.103.6-1.49.amzn1.x86_64
    clamav-devel-0.103.6-1.49.amzn1.x86_64
    clamav-lib-0.103.6-1.49.amzn1.x86_64

Vulnerable software versions

Amazon Linux AMI: All versions

clamav: before 0.103.6-1.49


CPE2.3 External links

http://alas.aws.amazon.com/ALAS-2022-1621.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Memory leak

EUVDB-ID: #VU62798

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-20785

CWE-ID: CWE-401 - Improper Release of Memory Before Removing Last Reference ('Memory Leak')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform DoS attack on the target system.

The vulnerability exists due memory leak when parsing HTML files. A remote attacker can pass specially crafted HTML file to the antivirus software, trigger memory leak and perform denial of service attack.

Mitigation

Update the affected packages:

i686:
    clamav-0.103.6-1.49.amzn1.i686
    clamav-db-0.103.6-1.49.amzn1.i686
    clamav-lib-0.103.6-1.49.amzn1.i686
    clamav-debuginfo-0.103.6-1.49.amzn1.i686
    clamav-devel-0.103.6-1.49.amzn1.i686
    clamav-update-0.103.6-1.49.amzn1.i686
    clamav-milter-0.103.6-1.49.amzn1.i686
    clamd-0.103.6-1.49.amzn1.i686

noarch:
    clamav-filesystem-0.103.6-1.49.amzn1.noarch
    clamav-data-0.103.6-1.49.amzn1.noarch

src:
    clamav-0.103.6-1.49.amzn1.src

x86_64:
    clamav-milter-0.103.6-1.49.amzn1.x86_64
    clamav-update-0.103.6-1.49.amzn1.x86_64
    clamd-0.103.6-1.49.amzn1.x86_64
    clamav-0.103.6-1.49.amzn1.x86_64
    clamav-db-0.103.6-1.49.amzn1.x86_64
    clamav-debuginfo-0.103.6-1.49.amzn1.x86_64
    clamav-devel-0.103.6-1.49.amzn1.x86_64
    clamav-lib-0.103.6-1.49.amzn1.x86_64

Vulnerable software versions

Amazon Linux AMI: All versions

clamav: before 0.103.6-1.49


CPE2.3 External links

http://alas.aws.amazon.com/ALAS-2022-1621.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) NULL pointer dereference

EUVDB-ID: #VU62801

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2022-20796

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in the scan verdict cache check. A remote attacker can pass specially crafted data to the application and perform a denial of service (DoS) attack.

Mitigation

Update the affected packages:

i686:
    clamav-0.103.6-1.49.amzn1.i686
    clamav-db-0.103.6-1.49.amzn1.i686
    clamav-lib-0.103.6-1.49.amzn1.i686
    clamav-debuginfo-0.103.6-1.49.amzn1.i686
    clamav-devel-0.103.6-1.49.amzn1.i686
    clamav-update-0.103.6-1.49.amzn1.i686
    clamav-milter-0.103.6-1.49.amzn1.i686
    clamd-0.103.6-1.49.amzn1.i686

noarch:
    clamav-filesystem-0.103.6-1.49.amzn1.noarch
    clamav-data-0.103.6-1.49.amzn1.noarch

src:
    clamav-0.103.6-1.49.amzn1.src

x86_64:
    clamav-milter-0.103.6-1.49.amzn1.x86_64
    clamav-update-0.103.6-1.49.amzn1.x86_64
    clamd-0.103.6-1.49.amzn1.x86_64
    clamav-0.103.6-1.49.amzn1.x86_64
    clamav-db-0.103.6-1.49.amzn1.x86_64
    clamav-debuginfo-0.103.6-1.49.amzn1.x86_64
    clamav-devel-0.103.6-1.49.amzn1.x86_64
    clamav-lib-0.103.6-1.49.amzn1.x86_64

Vulnerable software versions

Amazon Linux AMI: All versions

clamav: before 0.103.6-1.49


CPE2.3 External links

http://alas.aws.amazon.com/ALAS-2022-1621.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###