Improper input validation in Cloud Foundry uaa-release



Published: 2022-08-08
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-34169
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Bosh Release for the UAA
Server applications / Virtualization software

Vendor Cloud Foundry Foundation

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Improper input validation

EUVDB-ID: #VU65495

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-34169

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to compromise the affected system.

The vulnerability exists due to an integer truncation issue when processing malicious XSLT stylesheets. A remote non-authenticated attacker can pass specially crafted data to the application to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Bosh Release for the UAA: 75.0.0 - 75.21.0


CPE2.3 External links

http://github.com/cloudfoundry/uaa-release/releases/tag/v75.22.0

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###