Multiple vulnerabilities in Adobe Acrobat and Reader



Published: 2022-08-10 | Updated: 2022-08-19
Risk High
Patch available YES
Number of vulnerabilities 7
CVE-ID CVE-2022-35665
CVE-2022-35666
CVE-2022-35667
CVE-2022-35668
CVE-2022-35670
CVE-2022-35671
CVE-2022-35678
CWE-ID CWE-416
CWE-20
CWE-787
CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Adobe Acrobat
Client/Desktop applications / Office applications

Adobe Reader
Client/Desktop applications / Office applications

Vendor Adobe

Security Bulletin

This security bulletin contains information about 7 vulnerabilities.

1) Use-after-free

EUVDB-ID: #VU66331

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-35665

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF file, trigger a use-after-free error and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Improper input validation

EUVDB-ID: #VU66333

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-35666

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a improper input validation when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF file and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) Out-of-bounds write

EUVDB-ID: #VU66335

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-35667

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when parsing embedded fonts. A remote attacker can trick the victim to open a specially crafted PDF file, trigger an out-of-bounds write and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html
http://www.zerodayinitiative.com/advisories/ZDI-22-1112/

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) Improper input validation

EUVDB-ID: #VU66339

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-35668

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to a improper input validation when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF file and read system memory.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

5) Use-after-free

EUVDB-ID: #VU66338

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-35670

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to a use-after-free error when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF file, trigger a use-after-free error and read system memory.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

6) Out-of-bounds read

EUVDB-ID: #VU66340

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-35671

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to a boundary error when parsing embedded fonts. A remote attacker can trick the victim to open a specially crafted PDF file, trigger an out-of-bounds read and read system memory.



Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html
http://www.zerodayinitiative.com/advisories/ZDI-22-1115/

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

7) Out-of-bounds read

EUVDB-ID: #VU66341

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-35678

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to a boundary error when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF file, trigger an out-of-bounds read and read system memory.



Mitigation

Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229

Adobe Reader: 22.001.20142 - 22.001.20169, 2022.001.20085 - 2022.001.20117, 20.005.30331 - 20.005.30362, 2020.001.30002 - 2020.013.20074, 17.012.30227 - 17.012.30249, 2017.008.30051 - 2017.012.30229


CPE2.3 External links

http://helpx.adobe.com/security/products/acrobat/apsb22-39.html
http://www.zerodayinitiative.com/advisories/ZDI-22-1116/

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###