Multiple vulnerabilities in IBM InfoSphere Information Server



Published: 2022-08-10 | Updated: 2022-08-22
Risk Medium
Patch available YES
Number of vulnerabilities 5
CVE-ID CVE-2021-35561
CVE-2022-21496
CVE-2022-21434
CVE-2022-21443
CVE-2022-21299
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
IBM InfoSphere Information Server
Server applications / Database software

Vendor IBM Corporation

Security Bulletin

This security bulletin contains information about 5 vulnerabilities.

1) Improper input validation

EUVDB-ID: #VU57493

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-35561

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the Utility component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Install update from vendor's website.

Vulnerable software versions

IBM InfoSphere Information Server: 11.7


CPE2.3 External links

http://www.ibm.com/support/pages/node/6601685

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Improper input validation

EUVDB-ID: #VU62400

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21496

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the JNDI component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Install update from vendor's website.

Vulnerable software versions

IBM InfoSphere Information Server: 11.7


CPE2.3 External links

http://www.ibm.com/support/pages/node/6601685

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) Improper input validation

EUVDB-ID: #VU62401

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21434

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Install update from vendor's website.

Vulnerable software versions

IBM InfoSphere Information Server: 11.7


CPE2.3 External links

http://www.ibm.com/support/pages/node/6601685

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) Improper input validation

EUVDB-ID: #VU62402

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21443

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Install update from vendor's website.

Vulnerable software versions

IBM InfoSphere Information Server: 11.7


CPE2.3 External links

http://www.ibm.com/support/pages/node/6601685

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

5) Improper input validation

EUVDB-ID: #VU59727

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21299

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the JAXP component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Install update from vendor's website.

Vulnerable software versions

IBM InfoSphere Information Server: 11.7


CPE2.3 External links

http://www.ibm.com/support/pages/node/6601685

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###