Ubuntu update for linux-aws-hwe



Published: 2022-08-11 | Updated: 2022-09-28
Risk Low
Patch available YES
Number of vulnerabilities 13
CVE-ID CVE-2022-0494
CVE-2022-1048
CVE-2022-1195
CVE-2022-1652
CVE-2022-1679
CVE-2022-1729
CVE-2022-1734
CVE-2022-1974
CVE-2022-1975
CVE-2022-2586
CVE-2022-2588
CVE-2022-33981
CVE-2022-34918
CWE-ID CWE-200
CWE-416
CWE-362
CWE-248
CWE-415
CWE-843
Exploitation vector Local network
Public exploit Public exploit code for vulnerability #10 is available.
Public exploit code for vulnerability #11 is available.
Public exploit code for vulnerability #13 is available.
Vulnerable software
Subscribe
Ubuntu
Operating systems & Components / Operating system

linux-image-4.15.0-1104-oracle (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-virtual-hwe-16.04 (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-oracle (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-generic-hwe-16.04 (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-aws-hwe (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-gcp (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-gke (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-azure (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-4.15.0-1139-aws-hwe (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-4.15.0-191-lowlatency (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-4.15.0-191-generic (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-oem (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-4.15.0-1149-azure (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-lowlatency-hwe-16.04 (Ubuntu package)
Operating systems & Components / Operating system package or component

linux-image-4.15.0-1134-gcp (Ubuntu package)
Operating systems & Components / Operating system package or component

Vendor Canonical Ltd.

Security Bulletin

This security bulletin contains information about 13 vulnerabilities.

1) Information disclosure

EUVDB-ID: #VU64259

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-0494

CWE-ID: CWE-200 - Information Exposure

Exploit availability: No

Description

The vulnerability allows a local user to gain access to potentially sensitive information.

The vulnerability exists due to excessive data output in the scsi_ioctl() function in drivers/scsi/scsi_ioctl.c in the Linux kernel. A local user with a special user privilege (CAP_SYS_ADMIN or CAP_SYS_RAWIO) can gain unauthorized access to sensitive information on the system.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Use-after-free

EUVDB-ID: #VU63428

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1048

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to execute arbitrary code with elevated privileges.

The vulnerability exists due to a use-after-free error in the Linux kernel’s sound subsystem in the way a user triggers concurrent calls of PCM hw_params. A local user can execute arbitrary code with elevated privileges and perform a denial-of-service attack.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Use-after-free

EUVDB-ID: #VU63430

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1195

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform a denial of service attack.

The vulnerability exists due to a use-after-free error in the drivers/net/hamradio. A local user can cause a denial of service (DOS) when the mkiss or sixpack device is detached.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Use-after-free

EUVDB-ID: #VU64434

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1652

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to use-after-free error in the bad_flp_intr() function. A local user can execute a specially-crafted program to cause a denial of service condition on the system or escalate privileges on the system.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Use-after-free

EUVDB-ID: #VU64861

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1679

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error within the ath9k_htc_wait_for_target() function in the Linux kernel’s Atheros wireless adapter driver. A local user can execute arbitrary code with elevated privileges.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Race condition

EUVDB-ID: #VU64156

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1729

CWE-ID: CWE-362 - Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a race condition within sys_perf_event_open() in Linux kernel. A local user can exploit the race and gain unauthorized access to sensitive information and escalate privileges on the system.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Use-after-free

EUVDB-ID: #VU64082

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1734

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to Marvell NFC device driver implementation in the Linux kernel did not properly perform memory cleanup operations in some situations. A local user can trigger use-after-free to escalate privileges on the system.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Use-after-free

EUVDB-ID: #VU64263

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1974

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local privileged user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error in the Linux kernel's NFC core functionality due to a race condition between kobject creation and delete. A local attacker with CAP_NET_ADMIN privilege can leak kernel information and escalate privileges on the system.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

9) Uncaught Exception

EUVDB-ID: #VU64264

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-1975

CWE-ID: CWE-248 - Uncaught Exception

Exploit availability: No

Description

The vulnerability allows a remote attacker on the local network to perform a denial of service (DoS) attack.

The vulnerability exists due to an uncaught exception error in the Linux kernel. A remote attacker on the local network can perform a denial of service (DoS) attack.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

10) Use-after-free

EUVDB-ID: #VU66396

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-2586

CWE-ID: CWE-416 - Use After Free

Exploit availability: Yes

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error within the the netfilter subsystem implementation in Linux kernel when preventing one nft object from referencing an nft set in another nft table. A local user can trigger a use-after-free error and execute arbitrary code on the system with elevated privileges.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

11) Double Free

EUVDB-ID: #VU66397

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-2588

CWE-ID: CWE-415 - Double Free

Exploit availability: Yes

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a double free error within the network packet scheduler implementation in the route4_change() function in Linux kernel when removing all references to a route filter before freeing it. A local user can run a specially crafted program to crash the kernel or execute arbitrary code.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

12) Use-after-free

EUVDB-ID: #VU64944

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-33981

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a local user to perform denial of service attack.

The vulnerability exists due to a use-after-free error in drivers/block/floppy.c in the Linux kernel when deallocating raw_cmd in the raw_cmd_ioctl function(). A local user can trigger use-after-free and perform denial of service attack.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

13) Type Confusion

EUVDB-ID: #VU65360

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-34918

CWE-ID: CWE-843 - Access of Resource Using Incompatible Type ('Type Confusion')

Exploit availability: Yes

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists in the Linux kernel’s Netfilter subsystem in the way a user provides incorrect input of the NFT_DATA_VERDICT type. A local user can pass specially crafted data to the application, trigger a type confusion error and escalate privileges on the system.

Mitigation

Update the affected package linux-aws-hwe to the latest version.

Vulnerable software versions

Ubuntu: 14.04, 16.04

linux-image-4.15.0-1104-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-virtual-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oracle (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-generic-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gcp (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-gke (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1139-aws-hwe (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-lowlatency (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-191-generic (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-oem (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1149-azure (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-lowlatency-hwe-16.04 (Ubuntu package): before 4.15.01134.150~16.04.2

linux-image-4.15.0-1134-gcp (Ubuntu package): before 4.15.01134.150~16.04.2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5560-2

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###