Ubuntu update for epiphany-browser



Published: 2022-08-12
Risk High
Patch available YES
Number of vulnerabilities 4
CVE-ID CVE-2021-45085
CVE-2021-45086
CVE-2021-45087
CVE-2022-29536
CWE-ID CWE-79
CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Ubuntu
Operating systems & Components / Operating system

epiphany-browser (Ubuntu package)
Operating systems & Components / Operating system package or component

Vendor Canonical Ltd.

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) Cross-site scripting

EUVDB-ID: #VU59662

Risk: High

CVSSv3.1:

CVE-ID: CVE-2021-45085

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data when processing data passed via an "about: page" URL. A remote attacker can permanently store and execute arbitrary JavaScript code on the affected system, when the victim opens the Most Visited list tab (ephy-about:overview) in browser.

Mitigation

Update the affected package epiphany-browser to the latest version.

Vulnerable software versions

Ubuntu: 22.04, 20.04

epiphany-browser (Ubuntu package): before 3.36.4-0ubuntu2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5561-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Cross-site scripting

EUVDB-ID: #VU59663

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-45086

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data, because a server's suggested_filename is used as the pdf_name value in PDF.js. A remote attacker can and execute arbitrary HTML and script code in user's browser in context of vulnerable website.


Mitigation

Update the affected package epiphany-browser to the latest version.

Vulnerable software versions

Ubuntu: 22.04, 20.04

epiphany-browser (Ubuntu package): before 3.36.4-0ubuntu2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5561-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Cross-site scripting

EUVDB-ID: #VU59664

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-45087

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data when View Source mode or Reader mode is used. A remote attacker can execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Update the affected package epiphany-browser to the latest version.

Vulnerable software versions

Ubuntu: 22.04, 20.04

epiphany-browser (Ubuntu package): before 3.36.4-0ubuntu2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5561-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Out-of-bounds write

EUVDB-ID: #VU66422

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-29536

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing a long page title in the ephy_string_shorten() function in the UI process. A remote attacker can create a specially crafted website, trick the victim into visiting it, trigger an out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Update the affected package epiphany-browser to the latest version.

Vulnerable software versions

Ubuntu: 22.04, 20.04

epiphany-browser (Ubuntu package): before 3.36.4-0ubuntu2


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5561-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###