Multiple vulnerabilities in Apache Traffic Server



Published: 2022-08-15
Risk Medium
Patch available YES
Number of vulnerabilities 6
CVE-ID CVE-2021-37150
CVE-2022-25763
CVE-2022-28129
CVE-2022-31780
CVE-2022-31778
CVE-2022-31779
CWE-ID CWE-285
CWE-444
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Apache Traffic Server
Server applications / Web servers

Vendor Apache Foundation

Security Bulletin

This security bulletin contains information about 6 vulnerabilities.

1) Improper Authorization

EUVDB-ID: #VU66504

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-37150

CWE-ID: CWE-285 - Improper Authorization

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to sensitive information.

The vulnerability exists due to an error when handling different protocols and schemes. A remote attacker can send a specially crafted HTTP request, bypass implemented security restrictions and gain access unauthorized access to protected resources.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Apache Traffic Server: 9.1.0 - 9.1.2, 9.0.0 - 9.0.2, 8.1.0 - 8.1.4, 8.0.0 - 8.0.8


CPE2.3 External links

http://lists.apache.org/thread/rc64lwbdgrkv674koc3zl1sljr9vwg21

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Inconsistent interpretation of HTTP requests

EUVDB-ID: #VU66506

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-25763

CWE-ID: CWE-444 - Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform HTTP/2 request smuggling attacks.

The vulnerability exists due to improper validation of HTTP/2 requests. A remote attacker can send a specially crafted HTTP/2 request to the server and smuggle arbitrary HTTP headers.

Successful exploitation of vulnerability may allow an attacker to poison HTTP cache and perform phishing attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Apache Traffic Server: 9.1.0 - 9.1.2, 9.0.0 - 9.0.2, 8.1.0 - 8.1.4, 8.0.0 - 8.0.8


CPE2.3 External links

http://lists.apache.org/thread/rc64lwbdgrkv674koc3zl1sljr9vwg21

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) Inconsistent interpretation of HTTP requests

EUVDB-ID: #VU66507

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-28129

CWE-ID: CWE-444 - Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform HTTP request smuggling attacks.

The vulnerability exists due to improper validation of HTTP requests. A remote attacker can send a specially crafted HTTP request to the server and smuggle arbitrary HTTP headers.

Successful exploitation of vulnerability may allow an attacker to poison HTTP cache and perform phishing attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Apache Traffic Server: 9.1.0 - 9.1.2, 9.0.0 - 9.0.2, 8.1.0 - 8.1.4, 8.0.0 - 8.0.8


CPE2.3 External links

http://lists.apache.org/thread/rc64lwbdgrkv674koc3zl1sljr9vwg21

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) Inconsistent interpretation of HTTP requests

EUVDB-ID: #VU66508

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-31780

CWE-ID: CWE-444 - Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

Exploit availability: No

Description

The vulnerability allows a remote attacker to preform HTTP request smuggling attacks.

The vulnerability exists due to improper validation of HTTP/2 frames. A remote attacker can send a specially crafted HTTP/2 request to the server and smuggle arbitrary HTTP headers.

Successful exploitation of vulnerability may allow an attacker to poison HTTP cache and perform phishing attacks.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Apache Traffic Server: 9.1.0 - 9.1.2, 9.0.0 - 9.0.2, 8.1.0 - 8.1.4, 8.0.0 - 8.0.8


CPE2.3 External links

http://lists.apache.org/thread/rc64lwbdgrkv674koc3zl1sljr9vwg21

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

5) Inconsistent interpretation of HTTP requests

EUVDB-ID: #VU66505

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-31778

CWE-ID: CWE-444 - Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform HTTP request smuggling attacks.

The vulnerability exists due to improper validation of the Transfer-Encoding header. A remote attacker can send a specially crafted HTTP request to the server and smuggle arbitrary HTTP headers.

Successful exploitation of vulnerability may allow an attacker to poison HTTP cache and perform phishing attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Apache Traffic Server: 8.1.0 - 8.1.4, 8.0.0 - 8.0.8


CPE2.3 External links

http://lists.apache.org/thread/rc64lwbdgrkv674koc3zl1sljr9vwg21

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

6) Inconsistent interpretation of HTTP requests

EUVDB-ID: #VU66509

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-31779

CWE-ID: CWE-444 - Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

Exploit availability: No

Description

The vulnerability allows a remote attacker to preform HTTP request smuggling attacks.

The vulnerability exists due to improper validation of HTTP/2 headers. A remote attacker can send a specially crafted HTTP/2 request to the server and smuggle arbitrary HTTP headers.

Successful exploitation of vulnerability may allow an attacker to poison HTTP cache and perform phishing attacks.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Apache Traffic Server: 9.1.0 - 9.1.2, 9.0.0 - 9.0.2, 8.1.0 - 8.1.4, 8.0.0 - 8.0.8


CPE2.3 External links

http://lists.apache.org/thread/rc64lwbdgrkv674koc3zl1sljr9vwg21
http://www.debian.org/security/2022/dsa-5206

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###