Ubuntu update for unbound



Published: 2022-08-16
Risk Medium
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2022-30698
CVE-2022-30699
CWE-ID CWE-341
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Ubuntu
Operating systems & Components / Operating system

libunbound8 (Ubuntu package)
Operating systems & Components / Operating system package or component

unbound (Ubuntu package)
Operating systems & Components / Operating system package or component

libunbound2 (Ubuntu package)
Operating systems & Components / Operating system package or component

Vendor Canonical Ltd.

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Predictable from Observable State

EUVDB-ID: #VU66548

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-30698

CWE-ID: CWE-341 - Predictable from Observable State

Exploit availability: No

Description

The vulnerability allows a remote attacker to poison DNS cache.

The vulnerability exists due to the way Unbound handles delegation information expiration event. A remote attacker who controls a rouge DNS server can force the Unbound instance to cache incorrect information about subdomain delegation and permanently poison the DNS cache, e.g. perform the "ghost domain names" attack. 

The attack is carried out when Unbound is queried for a subdomain of a rogue domain name. The rogue nameserver returns delegation information for the subdomain that updates Unbound's delegation cache. This action can be repeated before expiry of the delegation information by querying Unbound for a second level subdomain which the rogue nameserver provides new delegation information. Since Unbound is a child-centric resolver, the ever-updating child delegation information can keep a rogue domain name resolvable long after revocation.

Mitigation

Update the affected package unbound to the latest version.

Vulnerable software versions

Ubuntu: 18.04, 20.04, 22.04

libunbound8 (Ubuntu package): before 1.9.4-2ubuntu1.3, 1.13.1-1ubuntu5.1

unbound (Ubuntu package): before 1.9.4-2ubuntu1.3, 1.13.1-1ubuntu5.1, 1.6.7-1ubuntu2.5

libunbound2 (Ubuntu package): before 1.6.7-1ubuntu2.5


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5569-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Predictable from Observable State

EUVDB-ID: #VU66547

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-30699

CWE-ID: CWE-341 - Predictable from Observable State

Exploit availability: No

Description

The vulnerability allows a remote attacker to poison DNS cache.

The vulnerability exists due to the way Unbound handles delegation information expiration event. A remote attacker who controls a rouge DNS server can force the Unbound instance to cache incorrect information about domain delegation and permanently poison the DNS cache, e.g. perform the "ghost domain names" attack. 

The attack is perform when Unbound is queried for a rogue domain name, which cached delegation information is about to expire. The rogue nameserver delays the response until the cached delegation information expires. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries.

Mitigation

Update the affected package unbound to the latest version.

Vulnerable software versions

Ubuntu: 18.04, 20.04, 22.04

libunbound8 (Ubuntu package): before 1.9.4-2ubuntu1.3, 1.13.1-1ubuntu5.1

unbound (Ubuntu package): before 1.9.4-2ubuntu1.3, 1.13.1-1ubuntu5.1, 1.6.7-1ubuntu2.5

libunbound2 (Ubuntu package): before 1.6.7-1ubuntu2.5


CPE2.3 External links

http://ubuntu.com/security/notices/USN-5569-1

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###