Denial of service in Splunk Enterprise



Published: 2022-08-16
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-37439
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Splunk Enterprise
Server applications / IDS/IPS systems, Firewalls and proxy servers

Vendor Splunk Inc.

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Input validation error

EUVDB-ID: #VU66554

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-37439

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of zip archives using the file monitoring input. A remote attacker can pass specially crafted .zip file to the application and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Splunk Enterprise: 8.1.0 - 8.1.10, 8.2.0 - 8.2.7


CPE2.3 External links

http://www.splunk.com/en_us/product-security/announcements/svd-2022-0803.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###