Debian update for epiphany-browser



Published: 2022-08-17
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-29536
CWE-ID CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Debian Linux
Operating systems & Components / Operating system

epiphany-browser (Debian package)
Operating systems & Components / Operating system package or component

Vendor Debian

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Out-of-bounds write

EUVDB-ID: #VU66422

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-29536

CWE-ID: CWE-787 - Out-of-bounds write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing a long page title in the ephy_string_shorten() function in the UI process. A remote attacker can create a specially crafted website, trick the victim into visiting it, trigger an out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Update epiphany-browser package to version 3.38.2-1+deb11u3.

Vulnerable software versions

Debian Linux: All versions

epiphany-browser (Debian package): before 3.38.2-1+deb11u3


CPE2.3 External links

http://www.debian.org/security/2022/dsa-5208

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###