SUSE update for java-1_8_0-openj9



Published: 2022-09-06 | Updated: 2023-01-19
Risk High
Patch available YES
Number of vulnerabilities 9
CVE-ID CVE-2021-41041
CVE-2022-21426
CVE-2022-21434
CVE-2022-21443
CVE-2022-21476
CVE-2022-21496
CVE-2022-21540
CVE-2022-21541
CVE-2022-34169
CWE-ID CWE-388
CWE-20
Exploitation vector Network
Public exploit Public exploit code for vulnerability #9 is available.
Vulnerable software
Subscribe
openSUSE Leap
Operating systems & Components / Operating system

java-1_8_0-openj9-javadoc
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-src
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-headless-debuginfo
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-headless
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-devel-debuginfo
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-devel
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-demo-debuginfo
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-demo
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-debugsource
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-debuginfo
Operating systems & Components / Operating system package or component

java-1_8_0-openj9-accessibility
Operating systems & Components / Operating system package or component

java-1_8_0-openj9
Operating systems & Components / Operating system package or component

Vendor SuSE

Security Bulletin

This security bulletin contains information about 9 vulnerabilities.

1) Error Handling

EUVDB-ID: #VU67029

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-41041

CWE-ID: CWE-388 - Error Handling

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to Java versions 8 and 11 fail to throw the exception captured during bytecode verification when verification is triggered by a MethodHandle invocation. A remote attacker can invoke unverified methods using MethodHandles and bypass implemented security restrictions.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Improper input validation

EUVDB-ID: #VU62399

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21426

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the JAXP component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Improper input validation

EUVDB-ID: #VU62401

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21434

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Improper input validation

EUVDB-ID: #VU62402

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-21443

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to perform service disruption.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Improper input validation

EUVDB-ID: #VU62398

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21476

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

The vulnerability exists due to improper input validation within the Libraries component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to gain access to sensitive information.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Improper input validation

EUVDB-ID: #VU62400

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21496

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the JNDI component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

7) Improper input validation

EUVDB-ID: #VU65497

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21540

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

The vulnerability exists due to improper input validation within the Hotspot component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to gain access to sensitive information.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

8) Improper input validation

EUVDB-ID: #VU65496

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-21541

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the Hotspot component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

9) Improper input validation

EUVDB-ID: #VU65495

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-34169

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: Yes

Description

The vulnerability allows a remote non-authenticated attacker to compromise the affected system.

The vulnerability exists due to an integer truncation issue when processing malicious XSLT stylesheets. A remote non-authenticated attacker can pass specially crafted data to the application to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode.

Mitigation

Update the affected package java-1_8_0-openj9 to the latest version.

Vulnerable software versions

openSUSE Leap: 15.3 - 15.4

java-1_8_0-openj9-javadoc: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-src: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-headless: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-devel: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-demo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debugsource: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-debuginfo: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9-accessibility: before 1.8.0.345-150200.3.24.1

java-1_8_0-openj9: before 1.8.0.345-150200.3.24.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223092-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###